Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 0.8.0, 0.8.1.1
    • Fix Version/s: 0.8.2.0
    • Component/s: core
    • Labels:
      None
    • Environment:
      Red Hat Enterprise Linux Server release 5.8 (Tikanga)
      - x64

      Description

      https://github.com/xerial/snappy-java/issues/38 issue

      snappy version 1.1.x

      org.xerial.snappy.SnappyError: [FAILED_TO_LOAD_NATIVE_LIBRARY] null
          at org.xerial.snappy.SnappyLoader.load(SnappyLoader.java:239)
          at org.xerial.snappy.Snappy.<clinit>(Snappy.java:48)
          at org.xerial.snappy.SnappyInputStream.hasNextChunk(SnappyInputStream.java:351)
          at org.xerial.snappy.SnappyInputStream.rawRead(SnappyInputStream.java:159)
          at org.xerial.snappy.SnappyInputStream.read(SnappyInputStream.java:142)
          at java.io.InputStream.read(InputStream.java:101)
          at kafka.message.ByteBufferMessageSet$$anonfun$decompress$1.apply$mcI$sp(ByteBufferMessageSet.scala:68)
          at kafka.message.ByteBufferMessageSet$$anonfun$decompress$1.apply(ByteBufferMessageSet.scala:68)
          at kafka.message.ByteBufferMessageSet$$anonfun$decompress$1.apply(ByteBufferMessageSet.scala:68)
          at scala.collection.immutable.Stream$.continually(Stream.scala:1129)
          at kafka.message.ByteBufferMessageSet$.decompress(ByteBufferMessageSet.scala:68)
          at kafka.message.ByteBufferMessageSet$$anon$1.makeNextOuter(ByteBufferMessageSet.scala:178)
          at kafka.message.ByteBufferMessageSet$$anon$1.makeNext(ByteBufferMessageSet.scala:191)
          at kafka.message.ByteBufferMessageSet$$anon$1.makeNext(ByteBufferMessageSet.scala:145)
          at kafka.utils.IteratorTemplate.maybeComputeNext(IteratorTemplate.scala:66)
          at kafka.utils.IteratorTemplate.hasNext(IteratorTemplate.scala:58)
      
      /tmp] ldd snappy-1.0.5-libsnappyjava.so
      ./snappy-1.0.5-libsnappyjava.so: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./snappy-1.0.5-libsnappyjava.so)
      ./snappy-1.0.5-libsnappyjava.so: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by ./snappy-1.0.5-libsnappyjava.so)
      	linux-vdso.so.1 =>  (0x00007fff81dfc000)
      	libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00002b554b430000)
      	libm.so.6 => /lib64/libm.so.6 (0x00002b554b731000)
      	libc.so.6 => /lib64/libc.so.6 (0x00002b554b9b4000)
      	libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00002b554bd0c000)
      	/lib64/ld-linux-x86-64.so.2 (0x00000033e2a00000)
      
      /tmp] ldd snappy-1.1.1M1-be6ba593-9ac7-488e-953e-ba5fd9530ee1-libsnappyjava.so
      ldd: warning: you do not have execution permission for `./snappy-1.1.1M1-be6ba593-9ac7-488e-953e-ba5fd9530ee1-libsnappyjava.so'
      	linux-vdso.so.1 =>  (0x00007fff1c132000)
      	libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00002b9548319000)
      	libm.so.6 => /lib64/libm.so.6 (0x00002b954861a000)
      	libc.so.6 => /lib64/libc.so.6 (0x00002b954889d000)
      	libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00002b9548bf5000)
      	/lib64/ld-linux-x86-64.so.2 (0x00000033e2a00000)
      

        Attachments

        1. patch.diff
          0.7 kB
          thinker0

          Activity

            People

            • Assignee:
              theduderog Roger Hoover
              Reporter:
              thinker0 thinker0
            • Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: