Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.1
    • Fix Version/s: 0.8.1.1
    • Component/s: packaging
    • Labels:

      Description

      Currently just binaries jars get published on Maven Central (see http://repo1.maven.org/maven2/org/apache/kafka/kafka_2.10/0.8.1/ ). Please also publish sources and javadoc jars.

        Issue Links

          Activity

          sslavic Stevo Slavic added a comment -

          Assigned issue to packaging component

          sslavic Stevo Slavic added a comment -

          This bug is caused by new and incomplete migration to gradle build, introduced in 0.8.1 through KAFKA-1171.
          Before this 0.8.0 had sources and javadoc jars published (see here)

          jjkoshy Joel Koshy added a comment -

          Will upload a patch today.

          jjkoshy Joel Koshy added a comment -

          Created reviewboard https://reviews.apache.org/r/20376/
          against branch origin/0.8.1

          jjkoshy Joel Koshy added a comment -

          The above patch should apply to trunk as well, but I will rebase if necessary. The docsJar_2_8_2 task fails for some reason, but all the other tasks pass.

          joestein Joe Stein added a comment -

          ./gradlew srcJar worked great

          however the docsJar_2_8_2 error is stopping ./gradlew releaseTarGzAll from working trying to get a stacktrace out of it

          joestein Joe Stein added a comment -

          i ran with stacktrace, debug and info https://gist.github.com/joestein/10803377#file-kafka-1362-L296 googled around a bit looks like a bug in 2.8.1 scaladoc itself https://issues.scala-lang.org/browse/SI-4284 but fixed in 2.9.0 not sure yet if there is a workaround or what exactly in the code is causing this that we can change to subvert it.

          sslavic Stevo Slavic added a comment -

          Consider dropping Scala 2.8.x support. I've just created a separate request for that (see KAFKA-1399)

          jjkoshy Joel Koshy added a comment -

          Joe Stein I think I ran across a similar bug report earlier, but couldn't explain why that would affect the 2.8.2 scaladoc build.

          jjkoshy Joel Koshy added a comment -

          We could just get rid of 2_8_2. We would still have 2_8_0

          joestein Joe Stein added a comment -

          2.8.0 is so much older and worse (arguably) and not used if we drop support for 2.8.2 we might as well do it for 2.8.0, we should have some consensus to-do that though IMHO it falls under "release plan" and would require a Lazy majority to pass.

          jjkoshy Joel Koshy added a comment -

          We could, but it's just that there are a couple of users on 2.8 still - including LinkedIn. Since only the docs jar task is failing, I thought it would be sufficient to just remove 2.8.2 from docsJarAll.

          joestein Joe Stein added a comment -

          ok

          jjkoshy Joel Koshy added a comment -

          Committed to both 0.8.1 and trunk

          Filed KAFKA-1406 to address the warnings when generating javadocs/scaladocs.

          dwegener Daniel Wegener added a comment -

          kafka_2.10-0.8.1.1-sources.jar in maven central ist empty (see http://search.maven.org/#artifactdetails%7Corg.apache.kafka%7Ckafka_2.10%7C0.8.1.1%7Cjar). Is this intentional?

          ianfriedman Ian Friedman added a comment -

          Echoing the comment about the sources jar being empty. Can we get a resolution on this please? Joel Koshy?

          bcalmac Bogdan Calmac added a comment -

          This issue should be reopened. The sources jar for 0.8.1.1 on Maven Central is empty.

          junrao Jun Rao added a comment -

          The maven issue should be fixed in kafka-1502.


            People

            • Assignee:
              jjkoshy Joel Koshy
              Reporter:
              sslavic Stevo Slavic
            • Votes:
              1 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development