Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 0.8.0
    • Component/s: packaging
    • Labels:
      None

      Description

      Upgrading to sbt 0.10.1 is a nice to have as sbt moves forward. Plus, it's a requirement for me to help publish Kafka to maven

      1. kafka-134-v3-draft.patch
        8 kB
        Joe Stein
      2. kafka-134-v2-draft.patch
        18 kB
        Neha Narkhede
      3. kafka_patch.txt
        23 kB
        Joshua Hartman

        Issue Links

          Activity

          Joshua Hartman created issue -
          Neha Narkhede made changes -
          Field Original Value New Value
          Link This issue incorporates KAFKA-15 [ KAFKA-15 ]
          Joshua Hartman added a comment -

          Better late than never.

          Joshua Hartman made changes -
          Attachment kafka_patch.txt [ 12503157 ]
          Joshua Hartman made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Jay Kreps added a comment -

          So Neha, can you review this patch. I would love to get this applied so we can get the eclipse support working again.

          Chris Burroughs added a comment -

          Is 0.10 still the most recent version, or would it be easier to just jump to 0.11?

          Jay Kreps added a comment -

          Well either way. The problem is I am totally lost in SBT with any version, but I feel the longer this sits the more it gets out of sync with all the various build files changes we are making. I tried to review this but basically failed after about 45 minutes of training to grok the weirdness of SBT, so i am hoping someone more experienced can take a shot.

          Neha Narkhede added a comment -

          This patch doesn't apply cleanly and has at least one bug -

          nnarkhed-ld:kafka-134 nnarkhed$ cat sbt
          java -Xmx1024M -XX:MaxPermSize=512m -jar `dirname $0`/sbt-launch.jar "$@"

          Even when the patch was uploaded sbt-launch.jar was never in the top-level directory. Was this patch developed against trunk ?
          Can you upload a patch that works against trunk ?

          Neha Narkhede added a comment -

          Attaching a patch that will apply cleanly against trunk. This is a draft patch, as I just took the previous patch and corrected -

          1. The sbt file to point to the lib directory for the sbt-launch.jar
          2. The sbt-launch.jar for 0.10.0
          3. svn delete on the old KafkaProject.scala and Plugins.scala files
          4. changed build.properties to change the SBT version to 0.10.0

          After these changes, the patch will apply cleanly against trunk, will pull SBT 0.10.0, but I still get the following error on the new Build.scala file -

          nnarkhed-ld:kafka-134 nnarkhed$ ./sbt
          [info] Set current project to default (in build file:/home/nnarkhed/Projects/kafka-134/project/plugins/)
          [info] Compiling 1 Scala source to /home/nnarkhed/Projects/kafka-134/project/target/scala_2.8.1/classes...
          [error] /home/nnarkhed/Projects/kafka-134/project/Build.scala:130: not found: value description
          [error] Error occurred in an application involving default arguments.
          [error] pomExtra <<= (pomExtra, name, description)

          { buildPomExtra }

          [error] ^
          [error] /home/nnarkhed/Projects/kafka-134/project/Build.scala:137: not found: value description
          [error] Error occurred in an application involving default arguments.
          [error] description := "Includes all of kafka project in one",
          [error] ^
          [error] two errors found

          I probably won't be able to work on this before KAFKA-198. Uploading this patch in case someone else wants to take a look.

          Neha Narkhede made changes -
          Attachment kafka-134-v2-draft.patch [ 12507123 ]
          Patricio Echague made changes -
          Link This issue blocks KAFKA-133 [ KAFKA-133 ]
          Joe Stein added a comment -

          we should look at going up to 11.2 now once we catch up maintence of it should not be so bad.

          if anyone else can take a look that would be great I can review it. I will check out what was done already maybe I can see where the issue is because I had similar problems to Neha when I tried it needs a clean once through

          Joe Stein added a comment -

          The patch applied for me

          Josephs-MacBook-Pro:kafka_134 josephstein$ patch -p0 -i ~/Downloads/kafka-134-v2-draft.latest.patch
          patching file sbt
          patching file project/build/KafkaProject.scala
          Reversed (or previously applied) patch detected! Assume -R? [n] y
          patching file project/plugins/Plugins.scala
          patching file project/Build.scala
          patching file project/build.properties

          and then I downloaded sbt 11.3 and when i do ./sbt compile i get this error (updated not required anymore)

          Josephs-MacBook-Pro:kafka_134 josephstein$ ./sbt compile
          [warn] Using project/plugins/ is deprecated for plugin configuration (/opt/apache/kafka_134/project/plugins).
          [warn] Put .sbt plugin definitions directly in project/,
          [warn] .scala plugin definitions in project/project/,
          [warn] and remove the project/plugins/ directory.
          [info] Loading project definition from /opt/apache/kafka_134/project/plugins
          [info] Set current project to root (in build file:/opt/apache/kafka_134/)
          [info] Compiling 137 Scala sources and 3 Java sources to /opt/apache/kafka_134/core/target/scala-2.9.1/classes...
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/consumer/ConsoleConsumer.scala:22: object I0Itec is not a member of package org
          [error] import org.I0Itec.zkclient._
          [error] ^
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/consumer/Fetcher.scala:22: object I0Itec is not a member of package org
          [error] import org.I0Itec.zkclient.ZkClient
          [error] ^
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/consumer/FetcherRunnable.scala:24: object I0Itec is not a member of package org
          [error] import org.I0Itec.zkclient.ZkClient
          [error] ^
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/utils/ZkUtils.scala:20: object I0Itec is not a member of package org
          [error] import org.I0Itec.zkclient.ZkClient
          [error] ^
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/consumer/TopicCount.scala:22: object I0Itec is not a member of package org
          [error] import org.I0Itec.zkclient.ZkClient
          [error] ^
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/consumer/ZookeeperConsumerConnector.scala:26: object I0Itec is not a member of package org
          [error] import org.I0Itec.zkclient.exception.ZkNodeExistsException
          [error] ^
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/consumer/ZookeeperConsumerConnector.scala:28: object I0Itec is not a member of package org
          [error] import org.I0Itec.zkclient.

          {IZkStateListener, IZkChildListener, ZkClient}
          [error] ^
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/consumer/ZookeeperConsumerConnector.scala:29: object zookeeper is not a member of package org.apache
          [error] import org.apache.zookeeper.Watcher.Event.KeeperState
          [error] ^
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/consumer/ZookeeperTopicEventWatcher.scala:22: object I0Itec is not a member of package org
          [error] import org.I0Itec.zkclient.{IZkStateListener, IZkChildListener, ZkClient}

          [error] ^
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/consumer/ZookeeperTopicEventWatcher.scala:23: object zookeeper is not a member of package org.apache
          [error] import org.apache.zookeeper.Watcher.Event.KeeperState
          [error] ^
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/message/CompressionUtils.scala:57: object xerial is not a member of package org
          [error] import org.xerial.snappy.SnappyInputStream
          [error] ^
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/message/CompressionUtils.scala:58: object xerial is not a member of package org
          [error] import org.xerial.snappy.SnappyOutputStream
          [error] ^
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/producer/ZKBrokerPartitionInfo.scala:25: object zookeeper is not a member of package org.apache
          [error] import org.apache.zookeeper.Watcher.Event.KeeperState
          [error] ^
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/producer/ZKBrokerPartitionInfo.scala:26: object I0Itec is not a member of package org
          [error] import org.I0Itec.zkclient.

          {IZkStateListener, IZkChildListener, ZkClient}

          [error] ^
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/server/KafkaZooKeeper.scala:22: object I0Itec is not a member of package org
          [error] import org.I0Itec.zkclient.

          {IZkStateListener, ZkClient}

          [error] ^
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/server/KafkaZooKeeper.scala:23: object I0Itec is not a member of package org
          [error] import org.I0Itec.zkclient.exception.ZkNodeExistsException
          [error] ^
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/server/KafkaZooKeeper.scala:24: object zookeeper is not a member of package org.apache
          [error] import org.apache.zookeeper.Watcher.Event.KeeperState
          [error] ^
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/tools/ConsumerOffsetChecker.scala:22: object I0Itec is not a member of package org
          [error] import org.I0Itec.zkclient.ZkClient
          [error] ^
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/tools/ExportZkOffsets.scala:23: object I0Itec is not a member of package org
          [error] import org.I0Itec.zkclient.ZkClient
          [error] ^
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/tools/ImportZkOffsets.scala:24: object I0Itec is not a member of package org
          [error] import org.I0Itec.zkclient.ZkClient
          [error] ^
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/utils/Utils.scala:31: object I0Itec is not a member of package org
          [error] import org.I0Itec.zkclient.ZkClient
          [error] ^
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/tools/ReplayLogProducer.scala:29: object I0Itec is not a member of package org
          [error] import org.I0Itec.zkclient._
          [error] ^
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/tools/VerifyConsumerRebalance.scala:21: object I0Itec is not a member of package org
          [error] import org.I0Itec.zkclient.ZkClient
          [error] ^
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/utils/UpdateOffsetsInZK.scala:20: object I0Itec is not a member of package org
          [error] import org.I0Itec.zkclient.ZkClient
          [error] ^
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/utils/ZkUtils.scala:21: object I0Itec is not a member of package org
          [error] import org.I0Itec.zkclient.serialize.ZkSerializer
          [error] ^
          [error] /opt/apache/kafka_134/core/src/main/scala/kafka/utils/ZkUtils.scala:25: object I0Itec is not a member of package org
          [error] import org.I0Itec.zkclient.exception.

          {ZkNodeExistsException, ZkNoNodeException, ZkMarshallingError}

          [error] ^
          [error] 26 errors found
          [error]

          {file:/opt/apache/kafka_134/}

          core/compile:compile: Compilation failed
          [error] Total time: 14 s, completed May 14, 2012 9:33:22 PM
          Josephs-MacBook-Pro:kafka_134 josephstein$

          noticed we should/could move some things into build.sbt probably some other linking issue now that lib_managed is in the ivy cache causing this error...

          seems something simple might be wrong here wanted to post my results in case anyone had any ideas? I will bang on this ticket some ... lots of community benefit to get a more update version going here IMHO

          Joe Stein added a comment -

          I have updated a new patch v3 https://gist.github.com/2699027 to resolve the issue I commented about when trying the previous patch

          I checked it compiles with SBT 0.11.3 http://typesafe.artifactoryonline.com/typesafe/ivy-releases/org.scala-sbt/sbt-launch/0.11.3/sbt-launch.jar

          new issue is that tests are not running at all just error

          Josephs-MacBook-Pro:kafka_134 josephstein$ ./sbt test
          [warn] Using project/plugins/ is deprecated for plugin configuration (/opt/apache/kafka_134/project/plugins).
          [warn] Put .sbt plugin definitions directly in project/,
          [warn] .scala plugin definitions in project/project/,
          [warn] and remove the project/plugins/ directory.
          [info] Loading project definition from /opt/apache/kafka_134/project/plugins
          [info] Set current project to root (in build file:/opt/apache/kafka_134/)
          [info] No tests to run for root/test:test
          [info] No tests to run for contrib/test:test
          [info] Compiling 45 Scala sources to /opt/apache/kafka_134/core/target/scala-2.9.1/test-classes...
          [info] No tests to run for perf/test:test
          [info] No tests to run for examples/test:test
          [info] No tests to run for hadoop-consumer/test:test
          [info] No tests to run for hadoop-producer/test:test
          [warn] there were 16 deprecation warnings; re-run with -deprecation for details
          [warn] one warning found
          [error] Could not run test kafka.message.ByteBufferMessageSetTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.log.LogCorruptionTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.integration.AutoOffsetResetTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.message.CompressionUtilTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.integration.BackwardsCompatibilityTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.consumer.ZookeeperConsumerConnectorTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.producer.AsyncProducerTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.consumer.TopicFilterTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.zk.ZKLoadBalanceTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.message.MessageTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.message.FileMessageSetTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.log.SegmentListTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.log.LogOffsetTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.utils.UtilsTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.producer.SyncProducerTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.javaapi.integration.PrimitiveApiTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test unit.kafka.producer.ProducerMethodsTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.javaapi.consumer.ZookeeperConsumerConnectorTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.javaapi.producer.SyncProducerTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.consumer.FetcherTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.log4j.KafkaLog4jAppenderTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.integration.LazyInitProducerTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.network.SocketServerTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.log.LogManagerTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.integration.PrimitiveApiTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.zk.ZKEphemeralTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.server.ServerShutdownTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.log.LogTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.javaapi.message.ByteBufferMessageSetTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.javaapi.producer.ProducerTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Could not run test kafka.producer.ProducerTest: java.lang.ClassCastException: scala.collection.immutable.Set$EmptySet$ cannot be cast to scala.collection.generic.Addable
          [error] Error: Total 0, Failed 0, Errors 0, Passed 0, Skipped 0
          [error] Error during tests:
          [error] kafka.log.LogManagerTest
          [error] kafka.log.LogTest
          [error] kafka.consumer.FetcherTest
          [error] kafka.integration.AutoOffsetResetTest
          [error] unit.kafka.producer.ProducerMethodsTest
          [error] kafka.javaapi.integration.PrimitiveApiTest
          [error] kafka.message.MessageTest
          [error] kafka.producer.ProducerTest
          [error] kafka.zk.ZKLoadBalanceTest
          [error] kafka.network.SocketServerTest
          [error] kafka.message.FileMessageSetTest
          [error] kafka.javaapi.producer.SyncProducerTest
          [error] kafka.javaapi.producer.ProducerTest
          [error] kafka.javaapi.consumer.ZookeeperConsumerConnectorTest
          [error] kafka.zk.ZKEphemeralTest
          [error] kafka.log.LogCorruptionTest
          [error] kafka.integration.LazyInitProducerTest
          [error] kafka.log.SegmentListTest
          [error] kafka.consumer.TopicFilterTest
          [error] kafka.consumer.ZookeeperConsumerConnectorTest
          [error] kafka.producer.AsyncProducerTest
          [error] kafka.log4j.KafkaLog4jAppenderTest
          [error] kafka.message.ByteBufferMessageSetTest
          [error] kafka.server.ServerShutdownTest
          [error] kafka.message.CompressionUtilTest
          [error] kafka.log.LogOffsetTest
          [error] kafka.javaapi.message.ByteBufferMessageSetTest
          [error] kafka.integration.BackwardsCompatibilityTest
          [error] kafka.integration.PrimitiveApiTest
          [error] kafka.utils.UtilsTest
          [error] kafka.producer.SyncProducerTest
          [error]

          {file:/opt/apache/kafka_134/}

          core/test:test: Tests unsuccessful
          [error] Total time: 31 s, completed May 15, 2012 12:05:45 AM

          Joe Stein made changes -
          Attachment kafka-134-v3-draft.patch [ 12527462 ]
          Chris Birchall added a comment -

          If you're interested, I have also had a stab at porting Kafka to SBT 0.11.3 and Scala 2.9.2. The code is available here:

          https://github.com/cb372/kafka-1

          It's all based on Kafka trunk, forked yesterday at revision 1339944.

          There are 3 branches:

          • sbt0.11.3 <-- SBT updated to 0.11.3, Scala still at 2.8.0
          • scala2.9.2 <-- SBT 0.11.3, Scala updated to 2.9.2
          • break2.8compatibility <-- SBT 0.11.3, Scala 2.9.2, all deprecation warnings fixed, code is now incompatible with Scala 2.8.x

          A few comments:

          • I'm no SBT guru so there may some craziness inside Build.scala. Hopefully it's understandable.
          • There is no fix for KAFKA-15 because I wasn't really sure of how it was supposed to work in the first place.
          • Worringly, after upgrading Scala to 2.9.2 about 1/3 of the tests started failing!
          • The reason that all the tests fail in Joe Stein's comment above is that ScalaTest has not been updated. Updating it to scalatest_2.9.2 v1.8 will fix this.
          • The run-rat.sh script had the jar's path hardcoded into it. Because the jar is now somewhere in the Ivy cache, rather than the lib_managed folder, I changed this so that SBT passes the jar's path to the script.

          Feel free to use any of this code, if it's of any help to you.

          Jay Kreps added a comment -

          This is great Chris. Guys, is there any objection to taking the scala2.9.2 branch? We should be able to cross-compile for 2.8 compatibility, right? I think it would be great to get this update done. It should probably be done one the 0.8 branch, though, right?

          Joe Stein added a comment -

          I think if we can get the latest scala and sbt working on trunk for a 0.7.2 release we would open the project to more of the community

          Joe Stein made changes -
          Summary Upgrade Kafka to sbt 0.10.1 Upgrade Kafka to sbt 0.11.3
          Joe Stein added a comment -

          << The reason that all the tests fail in Joe Stein's comment above is that ScalaTest has not been updated. Updating it to scalatest_2.9.2 v1.8 will fix this.

          ok, the tests are running now (great) but 75 tests are failing ( )

          looks like some issues

          [info] - testBasic(kafka.javaapi.consumer.ZookeeperConsumerConnectorTest) *** FAILED ***
          [info] java.net.BindException: Address already in use
          [info] at sun.nio.ch.Net.bind(Native Method)
          [info] at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:126)
          [info] at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:59)
          [info] at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:52)
          [info] at org.apache.zookeeper.server.NIOServerCnxn$Factory.<init>(NIOServerCnxn.java:144)
          [info] at org.apache.zookeeper.server.NIOServerCnxn$Factory.<init>(NIOServerCnxn.java:125)
          [info] at kafka.zk.EmbeddedZookeeper.<init>(EmbeddedZookeeper.scala:31)
          [info] at kafka.zk.ZooKeeperTestHarness$class.setUp(ZooKeeperTestHarness.scala:30)
          [info] at kafka.javaapi.consumer.ZookeeperConsumerConnectorTest.setUp(ZookeeperConsumerConnectorTest.scala:34)
          [info] at junit.framework.TestCase.runBare(TestCase.java:128)
          [info] ...

          and

          [info] - testCollateAndSerializeEvents *** FAILED ***
          [info] java.lang.AssertionError: Expectation failure on verify:
          [info] multiSend([ProducerRequest(test1$topic,1,75), ProducerRequest(test-topic,0,70), ProducerRequest(test-topic,1,70), ProducerRequest(test1$topic,0,75)]): expected: 1, actual: 0
          [info] at org.easymock.internal.MocksControl.verify(MocksControl.java:184)
          [info] at org.easymock.EasyMock.verify(EasyMock.java:2038)
          [info] at kafka.producer.AsyncProducerTest.testCollateAndSerializeEvents(AsyncProducerTest.scala:292)
          [info] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          [info] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
          [info] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          [info] at java.lang.reflect.Method.invoke(Method.java:597)
          [info] at org.junit.internal.runners.TestMethodRunner.executeMethodBody(TestMethodRunner.java:99)
          [info] at org.junit.internal.runners.TestMethodRunner.runUnprotected(TestMethodRunner.java:81)
          [info] at org.junit.internal.runners.BeforeAndAfterRunner.runProtected(BeforeAndAfterRunner.java:34)
          [info] ...

          are the two biggest culprits, guessing something with the scalatest updates from where we were to what is current.

          trunk on my same machine runs fine (so the address in use is not localized it is something in how the tests are running causing it)

          I tried the scala2.9.2 branch of Chris's github fork but got the same issue I had before (tests not even running)

          Joe Stein added a comment -

          when i use scalatest2.9.2 - 1.6.1 only 50 tests fail compared to the 74 failing with 1.8

          Joe Stein added a comment - - edited

          down to 1 test failing on trunk and a different 1 test failing on branch

          got things working better now by adding

          parallelExecution in Test := false

          into Build.scala 's buildSettings

          on trunk failure is

          [info] - testCollateAndSerializeEvents *** FAILED ***
          [info] java.lang.AssertionError: Expectation failure on verify:
          [info] multiSend([ProducerRequest(test1$topic,1,75), ProducerRequest(test-topic,0,70), ProducerRequest(test-topic,1,70), ProducerRequest(test1$topic,0,75)]): expected: 1, actual: 0
          [info] at org.easymock.internal.MocksControl.verify(MocksControl.java:184)
          [info] at org.easymock.EasyMock.verify(EasyMock.java:2038)
          [info] at kafka.producer.AsyncProducerTest.testCollateAndSerializeEvents(AsyncProducerTest.scala:292)
          [info] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          [info] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
          [info] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          [info] at java.lang.reflect.Method.invoke(Method.java:597)
          [info] at org.junit.internal.runners.TestMethodRunner.executeMethodBody(TestMethodRunner.java:99)
          [info] at org.junit.internal.runners.TestMethodRunner.runUnprotected(TestMethodRunner.java:81)
          [info] at org.junit.internal.runners.BeforeAndAfterRunner.runProtected(BeforeAndAfterRunner.java:34)
          [info] ...

          on 0.8 branch, testFailedSendRetryLogic is failing ...

          [info] Not expected (AsyncProducerTest.scala:483)

          Ismael Juma added a comment -

          "parallelExecution in Test := false" only prevents tests in the same subproject from running simultaneously. Is this what is intended? Unfortunately, SBT 0.10 and 0.11 are limited when it comes to controlling parallel execution. parallelExecution := false disables all parallel execution (including compilation). This is all explained in the wiki (https://github.com/harrah/xsbt/wiki/Parallel-Execution) along with details in the new and experimental mechanism in SBT 0.12.

          derek added a comment -

          Hmmm, I've already done work for upgrading to 0.11.3 on #139 (https://issues.apache.org/jira/browse/KAFKA-139). The test error you're seeing is because of a change in how EasyMock is used (see my notes in the ticket). Perhaps we should join forces (and tickets?) to get this pushed along.

          Gregoire Seux added a comment -

          The main server does not seem to start after including Chris patch : scala dep is missing (no more scala-library file in ../boot/ folder) and class path is still referencing scala 2.8.0.

          Joe Stein added a comment -

          all of the work has moved into KAFKA-139 to cross compile and upgrade to later SBT too

          Joe Stein made changes -
          Status Patch Available [ 10002 ] Open [ 1 ]
          Joe Stein made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Fix Version/s 0.8 [ 12317244 ]
          Resolution Duplicate [ 3 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              Joshua Hartman
            • Votes:
              4 Vote for this issue
              Watchers:
              9 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development