Uploaded image for project: 'Kafka'
  1. Kafka
  2. KAFKA-12954

Add Support for Scala 3 in 4.0.0

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: 4.0.0
    • Component/s: build
    • Labels:

      Description

      This is a follow up task from https://issues.apache.org/jira/browse/KAFKA-12895, in which Scala 2.12 support will be dropped.

      It would be good to, at the same time, add support for Scala 3.
      Initially it would be enough to only make the code compile with Scala 3 so we can generate the proper Scala 3 artifacts, this might be achieved with the proper compiler flags and an occasional rewrite.
      Follow up tasks could be created to migrate to a more idiomatic Scala 3 writing if desired.

      If I understand it correctly, this would need a KIP as we are modifying the public interfaces (new artifacts). If this is the case, let me know and I will write it.

        Attachments

          Activity

            People

            • Assignee:
              josep.prat Josep Prat
              Reporter:
              josep.prat Josep Prat
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: