Uploaded image for project: 'Kafka'
  1. Kafka
  2. KAFKA-1267

Corrupt 2.8.0_0.8.0 artifacts in maven central

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 0.8.0
    • Fix Version/s: 0.8.0
    • Component/s: clients
    • Labels:
      None
    • Environment:
      Affects 0.8.0 for Scala 2.8.0 only

      Description

      The kafka 0.8.0 jars on maven central for Scala 2.8.0 are corrupt ( the main jar is 5.1 kb in size when it should be 2.4 Mb). Since 2.8.0_0.8.0 is the only official downloadable Kafka version, and the corresponding jar for client apps is the only one that is corrupted, it's impossible to do a maven build without building a custom version of Kafka or overriding the maven central client jar.

      Please update the maven central artifacts associated with this release.
      http://search.maven.org/#artifactdetails|org.apache.kafka|kafka_2.8.0|0.8.0|jar

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              sarobenalt Steve Robenalt
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: