Uploaded image for project: 'Kafka'
  1. Kafka
  2. KAFKA-1164

kafka should depend on snappy 1.0.5 (instead of 1.0.4.1)

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: 0.8.1
    • Component/s: None
    • Labels:

      Description

      There is a bug in snappy 1.0.4.1, that makes it not work when using java 7, on MacOSX. This issue is fixed in snappy 1.0.5. We've confirmed this locally.

      https://github.com/ptaoussanis/carmine/issues/5

      So, the kafka distribution should update the KafkaProject.scala file to call out version 1.0.5 instead of 1.0.4.1. I believe this file is used when generating the pom.xml file for kafka.

        Attachments

        1. kafka-1164.patch
          3 kB
          Jason Rosenberg

          Activity

            People

            • Assignee:
              jbrosenberg@gmail.com Jason Rosenberg
              Reporter:
              jbrosenberg@gmail.com Jason Rosenberg
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: