Uploaded image for project: 'Kafka'
  1. Kafka
  2. KAFKA-1095

Kafka does not compile with sbt

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.10.1.0
    • Fix Version/s: None
    • Component/s: packaging
    • Labels:
      None
    • Environment:
      Linux 64bit, OpenJDK 1.7

      Description

      Expected behaviour:
      After `git pull`, `./sbt update` and `./sbt package` the current snapshot version should compile without errors.

      Current behaviour:
      It fails with different error messages. This is one possible error log: https://gist.github.com/mumrah/7086356
      With `./sbt "++2.10.1 package"` the errors are different but still results in a failed compile. Other scala versions fail, too.

      The responsible commit which leads to the error messages is unknown to me.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              mailq Marcel Lohmann
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: