Maven JXR
  1. Maven JXR
  2. JXR-92

${project.version} not substituted in xref/index.html for aggregate goal

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.3
    • Fix Version/s: None
    • Component/s: maven2 jxr plugin
    • Labels:
      None

      Description

      This is demonstrated in the existing 'aggregate' integration test. The resulting HTML contains:

       <div class="xleft">
              <span id="publishDate">Last Published: 2011-08-23</span>
                        &nbsp;| <span id="projectVersion">Version: ${project.version}</span>
                            </div>
      
      

      note that project.version isn't replaced by the actual version.

        Issue Links

          Activity

          Benson Margulies created issue -
          Benson Margulies added a comment -

          Duplicate of JXR-93.

          Benson Margulies made changes -
          Field Original Value New Value
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Duplicate [ 3 ]
          Assignee Benson Margulies [ bmargulies ]
          Benson Margulies made changes -
          Link This issue duplicates JXR-93 [ JXR-93 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 10:32:48 UTC 2015 [ 1428229968272 ]
          Mark Thomas made changes -
          Workflow jira [ 12722161 ] Default workflow, editable Closed status [ 12748913 ]
          Mark Thomas made changes -
          Project Import Mon Apr 06 00:07:28 UTC 2015 [ 1428278848796 ]
          Mark Thomas made changes -
          Workflow jira [ 12959688 ] Default workflow, editable Closed status [ 12996814 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          1h 32m 1 Benson Margulies 23/Aug/11 14:08

            People

            • Assignee:
              Benson Margulies
              Reporter:
              Benson Margulies
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development