Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.2 Final
    • Fix Version/s: 1.3
    • Labels:
      None
    • Environment:

      Operating System: Linux
      Platform: PC

    • Bugzilla Id:
      35911

      Description

      Using the following xpath, I get a NullPointerException, when trying to do a
      getPointer():

      //item[@mutable='1'][last()]

      My code and instance data are attached

        Activity

        chrisp@tangent.co.za Chris Picton added a comment -

        Created an attachment (id=15808)
        Source code exhibiting problem

        chrisp@tangent.co.za Chris Picton added a comment -

        Created an attachment (id=15809)
        Instance data for attached source

        dennisl@apache.org Dennis Lundberg added a comment -
            • COM-2259 has been marked as a duplicate of this bug. ***
        dmitri@plotnix.com Dmitri Plotnikov added a comment -

        Corrected behavior or PredicateContext in two ways:
        1) When reset, it must also reset its parent context
        2) When you have multiple chained predicates, all but the last one must collect
        their individual node sets.


          People

          • Assignee:
            Unassigned
            Reporter:
            chrisp@tangent.co.za Chris Picton
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development