Uploaded image for project: 'jUDDI'
  1. jUDDI
  2. JUDDI-644

Subscription Integration Listener SMTP Tests fail intermittently on Windows

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.3
    • Component/s: None
    • Labels:
      None
    • Environment:
      Windows 7

      Description

      This is due to an encoding problem.
      Returned email body is
      Body:<ns4:notify_subscriptionListener xmlns=3D"urn:uddi-org:api_v3" xmlns:ns2=3D="urn:uddi-org:sub_v3" xmlns:ns3=3D"http
      ://www.w3.org/2000/09/xmldsig#" xmln=s:ns4=3D"urn:uddi-org:subr_v3"><authInfo>authtoken:a77df8f8-c80a-4a0d-be78-=5f6cc6a
      f5115</authInfo><ns2:subscriptionResultsList><ns2:coveragePeriod><ns=2:startPoint>2013-08-28T22:41:32.204-04:00</ns2:sta
      rtPoint><ns2:endPoint>20=13-08-28T22:41:37.859-04:00</ns2:endPoint></ns2:coveragePeriod><ns2:subscri=ption brief=3D"fals
      e"><ns2:subscriptionKey>uddi:uddi.joepublisher.com:subsc=riptiononesmtp</ns2:subscriptionKey><ns2:subscriptionFilter><fi
      nd_service><=findQualifiers><findQualifier>exactMatch</findQualifier></findQualifiers><n=ame xml:lang=3D"en">Service One
      </name></find_service></ns2:subscriptionFilt=er><bindingKey>uddi:uddi.joepublisher.com:bindinglistenersmtp</bindingKey><
      =ns2:notificationInterval>P5D</ns2:notificationInterval><ns2:maxEntities>100=0</ns2:maxEntities><ns2:expiresAfter>2013-0
      9-27T22:41:32.204-04:00</ns2:exp=iresAfter></ns2:subscription><serviceList><listDescription><includeCount>1<=/includeCou
      nt><actualCount>1</actualCount><listHead>1</listHead></listDescr=iption><serviceInfos><serviceInfo serviceKey=3D"uddi:ud
      di.joepublisher.com:=serviceone" businessKey=3D"uddi:uddi.joepublisher.com:businessone"><name xm=l:lang=3D"en">Service O
      ne</name><name xml:lang=3D"es">Servicio Uno</name></=serviceInfo></serviceInfos></serviceList></ns2:subscriptionResultsL
      ist></ns=4:notify_subscriptionListener>

      Notice the "=" symbols everywhere. This is probably an artifact of an encoding process. A temporary work around is to do a find and replace = with nothing, but this is hardly a solution.

        Attachments

          Activity

            People

            • Assignee:
              spyhunter99 Alex O'Ree
              Reporter:
              spyhunter99 Alex O'Ree
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: