Uploaded image for project: 'jUDDI'
  1. jUDDI
  2. JUDDI-588

Default Juddi business has services with endpoints starting with ${juddi.server.baseurl}/juddiv3

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.1.5
    • Component/s: None
    • Labels:
      None

      Description

      Default Juddi business has services with endpoints starting with $

      {juddi.server.baseurl}

      /juddiv3. This isn't useful and should be replaced with either localhost or the hostname of the local machine. Something like

      String localhostname = java.net.InetAddress.getLocalHost().getHostName();

        Activity

        kurtstam Kurt T Stam added a comment -

        This is intended behavior; the juddi db can be shared by multiple jUDDI nodes, so on the way out it replaces the $

        {juddi.server.baseurl}

        with the address specified in that node's juddiv3.properties file. This is to support a distributed jUDDI deployment. However we need to make sure we covered "all the ways out" with the token replacement, and you are saying that "it doesn't work for Discovery URLs on business elements". So we may have a bug there. I will investigate. Should be an easy fix.

        kurtstam Kurt T Stam added a comment -

        Added token replacement for discoveryURL


          People

          • Assignee:
            kstam Kurt T Stam
            Reporter:
            spyhunter99 Alex O'Ree
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development