Uploaded image for project: 'jUDDI'
  1. jUDDI
  2. JUDDI-553

TModelDetail not deleted when TModel is deleted

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Not A Problem
    • Affects Version/s: 3.1.3
    • Fix Version/s: 3.1.5
    • Component/s: juddi-client
    • Labels:
      None

      Description

      I use the client to create a TModel (saveTModel) then a BusinessService (saveService) and finally a binding (saveBindings).

      I use getTModelDetail within SoapUI to get the details.

      Finally I deleteBinding, deleteTModel and then deleteService.

      I use gTModelDetail with soapUI using previous tModelKey which was deleted and I still get the tModelDetails back. The tmodel, binding and service have been deleted when I enquire on them from soapUI.

      It looks to me that the tModelDetails in the database are not being deleted.

        Activity

        swebb Steve Webb added a comment -

        Great thanks Kurt So it was an issue then, not just me imagining it.

        kurtstam Kurt T Stam added a comment -

        Hi Steve,

        Actually I just reread the spec on this and it is by design; we only logically delete the tModel:

        http://uddi.org/pubs/uddi_v3.htm#_Toc85908106

        The relevant section is:

        5.2.11.3 Behavior:
        If a tModel is hidden in this way it MUST not be physically deleted as a result of this call. Any tModels hidden in this way are still accessible, via the get_registeredInfo and get_tModelDetail APIs, but are omitted from any results returned by calls to find_tModel. All other inquiry APIs may include references to tModelKeys of deleted tModelKeys, and UDDI data structures that reference these tModels are found and retrieved.

        The purpose of the delete_tModel behavior is to ensure that the details associated with a hidden tModel are still available to anyone currently using the tModel. A hidden tModel can be restored and made visible to search results by invoking the save_tModel API at a later time, passing the original data and the tModelKey value of the hidden tModel.

        So if you do I 'find' a deleted model should NOT be found, but e 'get' should still work. Please reopen if your find method does return the tmodel.

        --Kurt


          People

          • Assignee:
            kstam Kurt T Stam
            Reporter:
            swebb Steve Webb
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development