Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.3
    • Fix Version/s: 3.1.5
    • Component/s: core
    • Labels:
      None

      Description

      The following exception currently hinders me from upgrading my platform to java7:

      org.xml.sax.SAXParseException: s4s-att-not-allowed: Attribute 'nillable' cannot appear in element 'element'.

      Here a possible solution was suggested: https://issues.apache.org/jira/browse/JUDDI-536?focusedCommentId=13175556&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-13175556
      Currently I use the workaround of running juddi with java6, but this is hindering me from completely upgrading to java7, because my junit tests fail when being run with java7.

      Any idea when this can get fixed?

      ----------------------------------

      Here is the complete stacktrace:
      2011-12-19 14:44:07,585 [ |qtp1530777310-23 ] WARN org.apache.cxf.wsdl.EndpointReferenceUtils.createSchema - SAXException for newSchema()
      org.xml.sax.SAXParseException: s4s-att-not-allowed: Attribute 'nillable' cannot appear in element 'element'.
      at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAXParseException(ErrorHandlerWrapper.java:198) ~[na:1.7.0_147-icedtea]
      at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.error(ErrorHandlerWrapper.java:134) ~[na:1.7.0_147-icedtea]
      at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(XMLErrorReporter.java:437) ~[na:1.7.0_147-icedtea]
      at com.sun.org.apache.xerces.internal.impl.xs.traversers.XSDHandler.reportSchemaErr(XSDHandler.java:4124) ~[na:1.7.0_147-icedtea]
      at com.sun.org.apache.xerces.internal.impl.xs.traversers.XSDHandler.reportSchemaError(XSDHandler.java:4107) ~[na:1.7.0_147-icedtea]
      at com.sun.org.apache.xerces.internal.impl.xs.traversers.XSAttributeChecker.reportSchemaError(XSAttributeChecker.java:1567) ~[na:1.7.0_147-icedtea]
      at com.sun.org.apache.xerces.internal.impl.xs.traversers.XSAttributeChecker.checkAttributes(XSAttributeChecker.java:1103) ~[na:1.7.0_147-icedtea]
      at com.sun.org.apache.xerces.internal.impl.xs.traversers.XSAttributeChecker.checkAttributes(XSAttributeChecker.java:961) ~[na:1.7.0_147-icedtea]
      at com.sun.org.apache.xerces.internal.impl.xs.traversers.XSDElementTraverser.traverseLocal(XSDElementTraverser.java:160) ~[na:1.7.0_147-icedtea]
      at com.sun.org.apache.xerces.internal.impl.xs.traversers.XSDHandler.traverseLocalElements(XSDHandler.java:3580) ~[na:1.7.0_147-icedtea]
      at com.sun.org.apache.xerces.internal.impl.xs.traversers.XSDHandler.parseSchema(XSDHandler.java:622) ~[na:1.7.0_147-icedtea]
      at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaLoader.loadSchema(XMLSchemaLoader.java:585) ~[na:1.7.0_147-icedtea]
      at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaLoader.loadGrammar(XMLSchemaLoader.java:552) ~[na:1.7.0_147-icedtea]
      at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaLoader.loadGrammar(XMLSchemaLoader.java:518) ~[na:1.7.0_147-icedtea]
      at com.sun.org.apache.xerces.internal.jaxp.validation.XMLSchemaFactory.newSchema(XMLSchemaFactory.java:227) ~[na:1.7.0_147-icedtea]
      at org.apache.cxf.wsdl.EndpointReferenceUtils.createSchema(EndpointReferenceUtils.java:693) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.apache.cxf.wsdl.EndpointReferenceUtils.getSchema(EndpointReferenceUtils.java:737) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.apache.cxf.interceptor.AbstractInDatabindingInterceptor.setSchemaInMessage(AbstractInDatabindingInterceptor.java:108) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.apache.cxf.interceptor.AbstractInDatabindingInterceptor.getDataReader(AbstractInDatabindingInterceptor.java:93) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.apache.cxf.interceptor.AbstractInDatabindingInterceptor.getDataReader(AbstractInDatabindingInterceptor.java:98) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.apache.cxf.interceptor.DocLiteralInInterceptor.handleMessage(DocLiteralInInterceptor.java:69) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.apache.cxf.phase.PhaseInterceptorChain.doIntercept(PhaseInterceptorChain.java:263) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.apache.cxf.transport.ChainInitiationObserver.onMessage(ChainInitiationObserver.java:121) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.apache.cxf.transport.http.AbstractHTTPDestination.invoke(AbstractHTTPDestination.java:206) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.apache.cxf.transport.servlet.ServletController.invokeDestination(ServletController.java:218) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.apache.cxf.transport.servlet.ServletController.invoke(ServletController.java:200) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.apache.cxf.transport.servlet.CXFNonSpringServlet.invoke(CXFNonSpringServlet.java:114) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.apache.cxf.transport.servlet.AbstractHTTPServlet.handleRequest(AbstractHTTPServlet.java:184) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.apache.cxf.transport.servlet.AbstractHTTPServlet.doPost(AbstractHTTPServlet.java:107) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:595) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.apache.cxf.transport.servlet.AbstractHTTPServlet.service(AbstractHTTPServlet.java:163) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:558) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:488) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:119) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:520) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:233) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:972) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:417) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:192) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:906) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:117) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:110) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.eclipse.jetty.server.Server.handle(Server.java:350) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.eclipse.jetty.server.HttpConnection.handleRequest(HttpConnection.java:442) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.eclipse.jetty.server.HttpConnection$RequestHandler.content(HttpConnection.java:941) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:801) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:218) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:52) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:586) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:44) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:598) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:533) [de.invesdwin.gemeinsam.integration.ws.registry-prod-0.1.3.jar:0.1.3]
      at java.lang.Thread.run(Thread.java:722) [na:1.7.0_147-icedtea]

        Activity

        kurtstam Kurt T Stam added a comment -

        Can you test the suggested fix? And attach a patch. I can commit it and roll it into the 3.1.4 release. Thx! --Kurt

        subes subes added a comment - - edited

        The fix was suggested by Daniel Kulp, so I don't exactly know how he intended to fix it and in this position I am unable to write a patch myself. Sorry.
        Daniel Kulp only said that a workaround for this inside juddi might be possible, but was unspecific about how to do it.

        Btw, thanks for your help so far with the issues I had previously with juddi and scout!

        kurtstam Kurt T Stam added a comment -

        What are the steps to reproduce this issue?

        subes subes added a comment -

        Forgot that

        Here I created a sample: http://invesdwin.de/public/de.invesdwin.common.integration.ws.registry-sample-0.2.0.zip
        You can start it via start.sh/start.bat. Make sure the "java" command points to java 7 (either edit your PATH or edit the start script).
        When the bootstrap finished, after a while the exception from above will be printed to console quite often.

        To debug this, you could import the project into eclipse, add the juddi source to the project and launch "de.invesdwin.common.webserver.Main" in debug mode.

        kurtstam Kurt T Stam added a comment -

        I just ran the build, tests and integration tests and the current code base works fine with java7.


          People

          • Assignee:
            kstam Kurt T Stam
            Reporter:
            subes subes
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development