jUDDI
  1. jUDDI
  2. JUDDI-451

dispositionReport was not recognized. (Does it exist in service WSDL?)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: None
    • Fix Version/s: 3.1.1
    • Component/s: CXF
    • Labels:
      None

      Description

      When, in the uddi-tck module using cxf rather then the sun reference implementation

      <!-- for JAXWS –
      <dependency>
      <groupId>org.apache.cxf</groupId>
      <artifactId>cxf-rt-frontend-jaxws</artifactId>
      <version>2.3.1</version>
      </dependency>
      -->
      <!-- -->
      <dependency>
      <groupId>com.sun.xml.ws</groupId>
      <artifactId>jaxws-rt</artifactId>
      <version>2.1.4</version>
      </dependency>

      I get:

      Caused by: org.apache.cxf.interceptor.Fault: Message part

      {urn:uddi-org:api_v3}

      dispositionReport was not recognized. (Does it exist in service WSDL?)
      at org.apache.cxf.interceptor.DocLiteralInInterceptor.handleMessage(DocLiteralInInterceptor.java:194)
      at org.apache.cxf.phase.PhaseInterceptorChain.doIntercept(PhaseInterceptorChain.java:255)
      at org.apache.cxf.endpoint.ClientImpl.onMessage(ClientImpl.java:755)
      at org.apache.cxf.transport.http.HTTPConduit$WrappedOutputStream.handleResponseInternal(HTTPConduit.java:2

      Whenever a dispositionReport is returned.

      Either this we don't have the right WSDLs on our classpath, or this is a bug in the clientside cxf, or something else completely.

      We should ask the help of the CXF project.

        Issue Links

          Activity

          Kurt T Stam added a comment -

          Maybe these are related.

          Kurt T Stam added a comment -

          No longer an issue.


            People

            • Assignee:
              Kurt T Stam
              Reporter:
              Kurt T Stam
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development