jUDDI
  1. jUDDI
  2. JUDDI-44

MySQL "InnoDB" complains of foreign keys with jUDDI schema

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 0.9rc3
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      Mac OS X 10.3.5, MySQL 4.0.21

      Description

      I prefer to use the "InnoDB" MySQL storage engine whenever possible because it is the only one that is ACID compliant. I tried to load the create_database.sql script though I got 3 errors. MySQL couldn't create the BUSINESS_SERVICE, BINDING_TEMPLATE, and PUBLISHER_ASSERTION tables for the same reason:
      ERROR 1005: Can't create table './juddi/<table-name-here>.frm' (errno: 150)
      This is an InnoDB error code that has to do with foreign key constraints. I've searched the net a bit and studied the SQL hard and I really can't figure out why it's failing.

      Good luck fixing this one.

        Activity

        Steve Viens added a comment -

        From the online MySQL Manual: InnoDB Error Codes

        1005 (ER_CANT_CREATE_TABLE)

        Cannot create table. If the error message string refers to errno 150, table creation failed because a foreign key constraint was not correctly formed.

        Source:
        http://dev.mysql.com/doc/mysql/en/innodb-error-codes.html

        Steve Viens added a comment -

        More information on MySQL InnoDB Foreign Key Constraints: http://dev.mysql.com/doc/mysql/en/innodb-foreign-key-constraints.html

        Steve Viens added a comment -

        Changing priority to Minor as this issue hasn't come up much (this is the only report I've seen). Not saying this isn't something that needs to be fixed - just that it shouldn't hold up the next release.

        Kurt T Stam added a comment -

        I'm not seeing this issue using mysql5. I think if we don't get any more reports on this in the next few weeks we should "reject" the issue, assuming it was a mysql4 problem.

        Kurt T Stam added a comment -

        Can no longer reproduce this. I ran with MySQL5. Please reopen if this is still an issue.


          People

          • Assignee:
            Kurt T Stam
            Reporter:
            David Smiley
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development