jUDDI
  1. jUDDI
  2. JUDDI-409

problems in digital signature on entity

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 3.1.5
    • Component/s: None
    • Labels:
      None

      Description

      Hi, when i'm quering in the juddi console a signed entity...

      <find_business xmlns="urn:uddi-org:api_v3">
      <name>An Apache jUDDI Node</name>
      <findQualifiers>
      <findQualifier>uddi:uddi.org:findqualifier:signaturepresent</findQualifier></findQualifiers>
      </find_business>

      the result count is one!!! but the root entity is not signed
      And if the root entity is signed...why the console don`t show me the public key or the signed info
      please help me!!
      thanks

        Issue Links

          Activity

          Kurt T Stam added a comment - - edited

          Hi Marcos,

          It looks like the signaturepresent is not fully implemented. We will add it to the 3.0.4 release. And as always, we love receiving patches .

          --Kurt

          Marcos added a comment -

          My root entity on juddiv3 is not signed(i think that...). But if the root entity is not signed . why the response on juddi portal console show me one entity???, that's the problem!!!!

          note: in my juddi server there is only one entity(the root entity)

          i think that the juddi console must show me zero entities, cause the root entity is not signed

          thanks

          Kurt T Stam added a comment -

          Hi Marcos, can you add the steps to reproduce, such as how you sign your entity etc.? Thx, Kurt


            People

            • Assignee:
              Kurt T Stam
              Reporter:
              Marcos
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development