Uploaded image for project: 'JSPWiki'
  1. JSPWiki
  2. JSPWIKI-871

Update very outdated dependency to nekohtml-0.9.5

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.10.1
    • Fix Version/s: 2.10.2
    • Component/s: None
    • Labels:
      None

      Description

      JSPWiki uses a very outdated version of nekohtml. This 0.9.5 version is almost 10 years old and comes with an also very outdated library of "xercesImpl-2.4.0".

      In our project (d3web/KnowWE) this xercesImpl-2.4.0 causes severe problems, because it replaces the default DocumentBuilder used to create XML documents, but also causes java.lang.AbstractMethodError, because the interface seems to no longer be compatible with the rest of our code, because of the age.

      In short, it would be very helpful if the dependency of nekohtml could be updated to something a little more up to date, for example nekohtml-1.9.19.
      This version also provides a new version of xerces no longer causing the AbstractMethodError.

        Attachments

        1. JSPWIKI-871.patch
          3 kB
          Harry Metske

          Activity

            People

            • Assignee:
              metskem Harry Metske
              Reporter:
              astriffler Albrecht Striffler
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: