JSPWiki
  1. JSPWiki
  2. JSPWIKI-758

should we drop support for RCS (Revision Control System) ?

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.9.1
    • Fix Version/s: 3.0
    • Component/s: Core & storage
    • Labels:
      None
    • Environment:

      All

      Description

      This is less or more of a poll if there is still the need for RCS support in JSPWiki.

      RCS (http://en.wikipedia.org/wiki/Revision_Control_System) was created in 1982), and my impression is that nobody is using it anymore (in JSPWiki).

      We do have quite some tweaks in the build scripts and so on.
      Dropping support would make the project again a bit more simple.

      Your votes please!

        Activity

        Harry Metske created issue -
        Juan Pablo Santos Rodríguez added a comment -

        + 1

        Michael Gerzabek added a comment -

        +1

        Harry Metske made changes -
        Field Original Value New Value
        Fix Version/s 3.0 [ 12312865 ]
        Harry Metske added a comment -

        We had more +1's :

        • lgilardoni61@gmail.com
        • Janne (for 3.0)
        Harry Metske added a comment -

        Deprecated in 2.9.1-svn-20.

        Glen Mazza added a comment -

        Does this mean we can remove org.apache.wiki.stress.StressTestRCSProvider from our tests? (Nice time saver if we can...)

        Glen Mazza added a comment -

        Actually, the above test fails anyway without an RCS provider:

        type="org.apache.wiki.providers.ProviderException">org.apache.wiki.providers.ProviderException: RCS checkin failed
        at org.apache.wiki.providers.RCSFileProvider.putPageText(RCSFileProvider.java:425)
        at org.apache.wiki.PageManager.putPageText(PageManager.java:305)
        at org.apache.wiki.PageManager$SaveWikiPageTask.execute(PageManager.java:747)
        at org.apache.wiki.workflow.Workflow.processCurrentStep(Workflow.java:763)
        at org.apache.wiki.workflow.Workflow.start(Workflow.java:678)
        at org.apache.wiki.workflow.WorkflowManager.start(WorkflowManager.java:79)
        at org.apache.wiki.WikiEngine.saveText(WikiEngine.java:1752)
        at org.apache.wiki.TestEngine.saveText(TestEngine.java:336)
        at org.apache.wiki.stress.StressTestRCSProvider.testMillionChanges(StressTestRCSProvider.java:99)
        Caused by: java.io.IOException: Cannot run program "ci" (in directory "/tmp/testrepository"): error=2, No such file or directory

        StressTestSpeed also needs updating for the new situation:

        Testsuite: org.apache.wiki.stress.StressTestSpeed
        Tests run: 2, Failures: 0, Errors: 2, Time elapsed: 24.863 sec

        Testcase: testSpeed1 took 13.366 sec
        Caused an ERROR
        RCS checkin failed
        org.apache.wiki.providers.ProviderException: RCS checkin failed
        at org.apache.wiki.providers.RCSFileProvider.putPageText(RCSFileProvider.java:425)
        at org.apache.wiki.providers.CachingProvider.putPageText(CachingProvider.java:584)
        at org.apache.wiki.PageManager.putPageText(PageManager.java:305)
        at org.apache.wiki.PageManager$SaveWikiPageTask.execute(PageManager.java:747)
        at org.apache.wiki.workflow.Workflow.processCurrentStep(Workflow.java:763)
        at org.apache.wiki.workflow.Workflow.start(Workflow.java:678)
        at org.apache.wiki.workflow.WorkflowManager.start(WorkflowManager.java:79)
        at org.apache.wiki.WikiEngine.saveText(WikiEngine.java:1752)
        at org.apache.wiki.TestEngine.saveText(TestEngine.java:336)
        at org.apache.wiki.stress.StressTestSpeed.testSpeed1(StressTestSpeed.java:84)
        Caused by: java.io.IOException: Cannot run program "ci" (in directory "/tmp/testrepository"): error=2, No such file or directory
        at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
        at java.lang.Runtime.exec(Runtime.java:615)
        at java.lang.Runtime.exec(Runtime.java:448)
        at org.apache.wiki.providers.RCSFileProvider.putPageText(RCSFileProvider.java:399)
        Caused by: java.io.IOException: error=2, No such file or directory
        at java.lang.UNIXProcess.forkAndExec(Native Method)
        at java.lang.UNIXProcess.<init>(UNIXProcess.java:135)
        at java.lang.ProcessImpl.start(ProcessImpl.java:130)
        at java.lang.ProcessBuilder.start(ProcessBuilder.java:1021)

        Other tests seem to work fine with this change.

        Harry Metske added a comment -

        OK with me, we won't break RCS support with that.

        Glen Mazza added a comment -

        RCS test removed, StressTestSpeed still failing as described above, I'll look at it later unless someone else gets to it first.

        Juan Pablo Santos Rodríguez added a comment -

        done in 2.10.0-svn-57

        Juan Pablo Santos Rodríguez made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        340d 2h 48m 1 Juan Pablo Santos Rodríguez 17/Dec/13 20:40

          People

          • Assignee:
            Unassigned
            Reporter:
            Harry Metske
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development