Uploaded image for project: 'JSPWiki'
  1. JSPWiki
  2. JSPWIKI-725

Return to original page attachments list after deleting one attachment

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.8.4
    • Fix Version/s: 2.8.5, 2.9
    • Environment:

      Windows 2003 R2, Tomcat 6.0.20, Mozilla Firefox 11.0

      Description

      Reproduce Steps:
      1. Upload one attachment to some page
      2. Delete the attachment by Administrator account

      Expected Result:
      Page referred to the original page Attach tab

      Actual Result:
      It says that the page named by the format "PageNameAttachmentName" does not exist, why don't you go and create it? For example, if you delete attachment "2012.png" from page "Wiki Center", the page will be referred to page "Wiki Center2012.png" and in View tab, it says "This page does not exist. Why don't you go and create it?".

      1. JSPWIKI-725.patch
        0.5 kB
        Harry Metske

        Activity

        metskem Harry Metske added a comment -

        Suggesting the attached patch for Delete.jsp...

        wengm Bruce Wen added a comment -

        With the update, the page goes back to View tab but not Attach tab. I tried, it seems it's impossible to make it remain on Attach tab, is it right?

        metskem Harry Metske added a comment -

        Hmmm, in my situation, I go back to the Info Tab...
        I don't know how or why...

        wengm Bruce Wen added a comment -

        Right, with the attached patch, the page really go back to the Info tab. It can also go back to View tab if change WikiContext.INFO to WikiContext.VIEW. However, it cannot go back to Attach tab with similar way.

        metskem Harry Metske added a comment -

        yes of course, you are right.
        So you prefer going back to the view tab instead of the info tab?

        regards,
        Harry

        wengm Bruce Wen added a comment -

        I prefer going back to Attach tab.

        metskem Harry Metske added a comment -

        Fixed in 2.8.5-svn-12 and 2.9.0-svn-8.

        We redirect to the INFO tab, feel free to re-open and attach a patch for redirecting to the attach tab.

        florianh Florian Holeczek added a comment -

        Closing this, since 2.9 has been released


          People

          • Assignee:
            metskem Harry Metske
            Reporter:
            wengm Bruce Wen
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development