JSPWiki
  1. JSPWiki
  2. JSPWIKI-490

image preview impossible if image name contains special characters

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.8.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      We uploaded an image called pm²logo.gif to one of our wiki pages. Clicking on the image link for the attachment page gave a correct image. Embedding this image on a wiki page was also ok : [pm²logo.gif].

      Visualing this image with the image preview on the attachment page (by clicking on the >> sign) resulted in an image not being shown.

      If we changed the "²" in the filename to another character, eg "2", the image preview behaves correctly. This lead us in supposing that the image preview could have a problem with special characters in the file name.

        Activity

        Florian Holeczek made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Assignee brushed [ brushed ]
        Florian Holeczek made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Won't Fix [ 2 ]
        Bruno Peeters made changes -
        Attachment picture-with-².gif [ 12399450 ]
        brushed made changes -
        Field Original Value New Value
        Assignee Dirk Frederickx [ brushed ]
        Bruno Peeters created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Bruno Peeters
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development