Details

    • Type: Task Task
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.10.1
    • Component/s: Default template
    • Labels:
      None

      Description

      Current trunk includes "posteditor.js", which is not only responsible for JSPWIKI-380, the licensing also does not allow it to be included in an Apache project.

      The licensing conditions say exactly:

      License:
      MIT-style license.

      However, this is not legally binding at all - the license conditions MUST be explicitly stated. "MIT-style" could mean anything...

      Therefore, I propose we drop posteditor.js and all the related functionality asap.

        Issue Links

          Activity

          brushed added a comment -

          This is not an obvious one, as most toolbar functionality relies on the posteditor functionality.
          For the rest we could drop is, as it mainly provide support for the tab-completion and automatic bracks, which are not core to jspwiki.

          I'll need some time to rewrite the toolbar functionality.

          dirk

          Janne Jalkanen added a comment -

          The problem is really with the license, not with the functionality (though it is quite a mess too; little comments and non-obvious variable names).

          What exactly is needed for the toolbar functionality? I tried disabling posteditor.js completely, and couldn't find anything that didn't work (aside from tab-completion and smart brackets).

          Janne Jalkanen added a comment -

          Hmm... On second thought, since 2.8 isn't going to be an official Apache release, ASF won't have to suffer from any license problems. So I guess we could keep posteditor.js for 2.8, and then get rid of it for 3.0.

          However, JSPWIKI-380 needs to be resolved. It's REALLY annoying me...

          Janne Jalkanen added a comment -

          In fact, since any replacement is likely to be a BIG chunk of untested code, I'd actually really prefer to keep posteditor.js for 2.8... Else the release will take a long, long time.

          brushed added a comment -

          Agree for the 2.8. Changing now may need some more time to burn in.

          I will consider a rewrite on 3.0, simplifying and removing the things we don't need.

          dirk

          brushed added a comment -

          Posteditor.js will be replaced in v3.0 by a jspwiki native implementation.
          It will mainly aim at a simplified snippet definition and IE compatibility.

          dirk

          Harry Metske added a comment -

          Any progress on this one Dirk ?

          Andrew Jaquith added a comment -

          Removed in 3.0.0-svn-207. Dirk, if and when you want to re-add this feature, feel free after we get to an Alpha build. But in the meantime, I felt it was best to remove it so we can graduate.

          brushed added a comment -

          Thanks )

          The need of posteditor.js was removed already several versions back.
          But I wanted to keep this jira open till the new snipeditor was at the same functional level as the posteditor.

          dirk

          Harry Metske added a comment -

          not completely fixed in 2.8 (which is now graduation candidate)

          Juan Pablo Santos Rodríguez added a comment -

          postEditor's site (http://icebeat.bitacoras.com/mootools/posteditor) now explicitly states that it's licensed under MIT license.

          If needed, we can reach postEditor author in order to get the license into the .js file, but I think that it's enough as it is right now (we ship a minified version of the library)..

          brushed added a comment -

          I assume we can remove posteditor also in v2.8. I need to check this out.
          dirk

          Florian Holeczek added a comment -

          needs to be fixed in 2.9; also marking for Graduating

          Juan Pablo Santos Rodríguez added a comment -

          do we need to fix this in order to graduate? It doesn't seem to me to be a license issue anymore :-?

          Florian Holeczek added a comment -

          We need to fix it "somehow" - if the now valid license is Apache compatible, the fix could also be documenting this like the others.

          Juan Pablo Santos Rodríguez added a comment -

          LICENSE file updated in 2.9.0-svn-4, so removing Graduation version from Affects/Fix version.

          Harry Metske added a comment -

          Looking at latest updates, to me it looks like it can closed ?

          Juan Pablo Santos Rodríguez added a comment -

          The license issue has been fixed, however posteditor.js lacks of IE support so, may be we can keep this one open, but setting priority to "Minor" and Issue Type to either "Improvement" or "Wish"?

          Also, I've removed the Fix Version/s field: 2.9 was tagged a few days ago and we're not working on 3.0 anymore.

          Florian Holeczek added a comment -

          Dirk, what is your opinion on Juan Pablo's suggestion?

          I don't completely understand what problems are remaining. Is anything not working with IE? If so, is the current trunk affected?

          Maybe we can close this one and create a new issue with some details attached?

          Regards
          Florian

          brushed added a comment -

          @Florian

          The posteditor.js is only compatible with safari and firefox. (probably also chrome) IE support was never intended by the author.

          As soon as jspwiki graduation is completed, I plan to do a major update of the plain editor. Parts of it were already committed in v3.0.0. That update will remove the need of the posteditor.js. So, I suggest to leave this jira issue till then.

          dirk

          brushed added a comment -

          Fixed in the HADDOCK TEMPLATE v2.10.1.svn.10,
          The he functionality, previously implemented by posteditor.js, is now covered as part of the redesigned plain editor javascript classes.

          dirk


            People

            • Assignee:
              brushed
              Reporter:
              Janne Jalkanen
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development