JSPWiki
  1. JSPWiki
  2. JSPWIKI-37

Change headers in all source code to Apache License

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8
    • Component/s: None
    • Labels:
      None

      Description

      We need to be slightly careful with this and only change the files where proper CLAs have been obtained.

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          217d 50m 1 Janne Jalkanen 19/Jun/08 23:20
          Resolved Resolved Closed Closed
          1178d 1h 16m 1 Florian Holeczek 11/Sep/11 00:36
          Florian Holeczek made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Andrew Jaquith added a comment -

          Woo-hoo!

          Janne Jalkanen made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]
          Janne Jalkanen added a comment -

          Resolved in 2.7.0-svn-47.

          Janne Jalkanen added a comment -

          All that remain under GPL currently (2.7.0-svn-42) are

          ./src/com/ecyrd/jspwiki/tags/EditorIteratorInfo.java
          ./src/com/ecyrd/jspwiki/tags/EditorIteratorTag.java
          ./src/com/ecyrd/jspwiki/ui/Editor.java
          ./src/com/ecyrd/jspwiki/ui/EditorManager.java

          Janne Jalkanen made changes -
          Link This issue is blocked by JSPWIKI-251 [ JSPWIKI-251 ]
          Janne Jalkanen made changes -
          Link This issue is blocked by JSPWIKI-246 [ JSPWIKI-246 ]
          Janne Jalkanen made changes -
          Link This issue is blocked by JSPWIKI-247 [ JSPWIKI-247 ]
          Janne Jalkanen made changes -
          Link This issue is blocked by JSPWIKI-248 [ JSPWIKI-248 ]
          Janne Jalkanen made changes -
          Link This issue is blocked by JSPWIKI-249 [ JSPWIKI-249 ]
          Janne Jalkanen made changes -
          Field Original Value New Value
          Link This issue is blocked by JSPWIKI-250 [ JSPWIKI-250 ]
          Janne Jalkanen added a comment -

          The first pass at the source files is now done. The following ones are tagged because there are suspicious things about them (either the author has not sent a CLA, it has not been confirmed as received, or the author is unclear). This thread should be amended when things are clarified. If a file cannot be properly cleared, it will need to be removed from the distribution (or a new replacement will need to be created).

          Missing CLAs:

          ./src/com/ecyrd/jspwiki/filters/CreoleFilter.java
          ./src/com/ecyrd/jspwiki/parser/CreoleToJSPWikiTranslator.java
          ./src/com/ecyrd/jspwiki/plugin/IndexPlugin.java
          ./src/com/ecyrd/jspwiki/search/BasicSearchProvider.java
          ./src/com/ecyrd/jspwiki/search/LuceneSearchProvider.java
          ./src/com/ecyrd/jspwiki/search/SearchManager.java
          ./src/com/ecyrd/jspwiki/search/SearchProvider.java
          ./src/com/ecyrd/jspwiki/tags/EditorIteratorInfo.java
          ./src/com/ecyrd/jspwiki/tags/EditorIteratorTag.java
          ./src/com/ecyrd/jspwiki/ui/Editor.java
          ./src/com/ecyrd/jspwiki/ui/EditorManager.java

          Unconfirmed CCLA (BaseN corporation):

          ./src/com/ecyrd/jspwiki/forms/FormClose.java
          ./src/com/ecyrd/jspwiki/forms/FormElement.java
          ./src/com/ecyrd/jspwiki/forms/FormHandler.java
          ./src/com/ecyrd/jspwiki/forms/FormInfo.java
          ./src/com/ecyrd/jspwiki/forms/FormInput.java
          ./src/com/ecyrd/jspwiki/forms/FormOpen.java
          ./src/com/ecyrd/jspwiki/forms/FormOutput.java
          ./src/com/ecyrd/jspwiki/forms/FormSelect.java
          ./src/com/ecyrd/jspwiki/forms/FormSet.java
          ./src/com/ecyrd/jspwiki/forms/FormTextarea.java
          ./src/com/ecyrd/jspwiki/util/FormUtil.java

          Unclear contributor/author (=Janne suspects someone contributed a big chunk of code but needs to check it from the history who it was):

          ./src/com/ecyrd/jspwiki/PageRenamer.java
          ./src/com/ecyrd/jspwiki/TextUtil.java

          Janne Jalkanen created issue -

            People

            • Assignee:
              Unassigned
              Reporter:
              Janne Jalkanen
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development