JSPWiki
  1. JSPWiki
  2. JSPWIKI-238

User Preferences - ComboBox with editors is empty

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Hi guys
      User Preferences page - try to change editor in JSPWiki v2.7.0-svn-0. The ComboBox, that should contain editors is empty.
      I've downloaded 2.6.2 version WAR file, installed and it's ok.
      Do you have any solutions or comments?

        Activity

        Hide
        David Au added a comment -

        Yup, it's been fixed.

        Show
        David Au added a comment - Yup, it's been fixed.
        Hide
        Janne Jalkanen added a comment -

        So, is this fixed now?

        Show
        Janne Jalkanen added a comment - So, is this fixed now?
        Hide
        Ihor Slabkyy added a comment -

        I took 2.6.2-rc4 version, did as says <a href="http://www.jspwiki.org/wiki/HowToManuallyIntegrateFCKEditor">HowToManuallyIntegrateFCKEditor</a> page and it works perfectly.

        Show
        Ihor Slabkyy added a comment - I took 2.6.2-rc4 version, did as says <a href="http://www.jspwiki.org/wiki/HowToManuallyIntegrateFCKEditor">HowToManuallyIntegrateFCKEditor</a> page and it works perfectly.
        Hide
        David Au added a comment -

        JP is correct – the FCK.jar file on the HowToManuallyIntegrateFCKEditor page contains an older jspwiki_modules.xml. I have now updated the FCK.jar file so that the editors don't have a maxValue attribute. It should now work with JSPWiki 2.6 or later.

        Show
        David Au added a comment - JP is correct – the FCK.jar file on the HowToManuallyIntegrateFCKEditor page contains an older jspwiki_modules.xml. I have now updated the FCK.jar file so that the editors don't have a maxValue attribute. It should now work with JSPWiki 2.6 or later.
        Hide
        Juan Pablo Santos Rodríguez added a comment -

        Hmm

        I think this issue may be caused because your jspwiki_modules.xml file (under $JSPWIKI/etc/ini) has defined for both plain and wikiwizard editors a maxValue attribute of 2.6, hence not showing them under 2.7.0. According to svn log, this attribute has been changed to 2.8 in 2.7.0-svn-4

        regards,
        jp

        Show
        Juan Pablo Santos Rodríguez added a comment - Hmm I think this issue may be caused because your jspwiki_modules.xml file (under $JSPWIKI/etc/ini) has defined for both plain and wikiwizard editors a maxValue attribute of 2.6, hence not showing them under 2.7.0. According to svn log, this attribute has been changed to 2.8 in 2.7.0-svn-4 regards, jp

          People

          • Assignee:
            Unassigned
            Reporter:
            Ihor Slabkyy
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development