Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.7.x
    • Fix Version/s: 2.8
    • Component/s: Editors
    • Labels:
      None
    • Environment:

      JSPWiki v2.7.0-svn-4

      Description

      I'm using the plain text editor and have just seen that some edit controls are missing. See the attached screenshot.

      1. jspwiki_missing_edit_controls.png
        28 kB
        florian1978
      2. EditControls.png
        163 kB
        Harry Metske
      3. editpage-ff3.jpg
        90 kB
        florian1978
      4. editpage-ie7.jpg
        67 kB
        florian1978

        Activity

        Harry Metske added a comment -

        With me it's working fine (2.7.0-svn4).

        Maybe flush your browser cache ?

        florian1978 added a comment -

        Weird... i had already tried this... did you flush yours?

        Harry Metske added a comment -

        I did not flush my browser cache, but pressed Ctrl-F5. I had some other weird displays before that.
        After Ctrl-F5 they were gone, and I can't find any errors yet. (see attached screen print)
        (And I'm so glad sectional editing is back again, I hope it can stay, despite some issues )

        florian1978 added a comment -

        I didn't change anything and suddenly it worked... well, this issue is invalid then!

        brushed added a comment -

        @Florian,

        Which browser are you using ? I haven't tested yet on IE.
        Could you check if any javascript errors are being logged. Could be helpful info.

        dirk

        florian1978 added a comment -

        see above.

        florian1978 added a comment -

        Lousy day
        In the beginning, it didn't work with both FF2 and IE7.
        Then, FF2 suddenly worked.
        However, IE7 still doesn't work. How do I open a JS debug console on IE7?

        Janne Jalkanen added a comment -

        Tagged for 2.8

        Harry Metske added a comment -

        Florian, does this problem still occur on the latest development version ?

        florian1978 added a comment -

        Just tested on svn-43 ... It's not exactly the same problem any more, but it's looking weird both on IE7 and FF3! I'll attach two screenshots.

        florian1978 added a comment -

        svn-43 on Firefox 3

        florian1978 added a comment -

        svn-43 on Internet Explorer 7

        brushed added a comment -

        Click the "+" next to the "Toolbar" label to open the edit controls.

        dirk

        florian1978 added a comment -

        That's clear, but what about the referencing pages "FIXME" and "?editor.plain.sneakpreview?" ?
        I guess that "page name" and "toolbar" aren't localized yet, too?
        Should I open an new issue on this?

        Janne Jalkanen added a comment -

        The "???" comes from the fact that the German translation is not up to date - unfortunately the Javascript code does not fall back to the default language.

        florian1978 added a comment -

        Ok...

        • I've updated the translation and documented some issues in another place.
        • The page name line along with the FIXME text is gone now... Is this intended behaviour or an error?

        Apart from this: I'd say this issue can be closed now because the original error doesn't exist any more.

        brushed added a comment -

        The FIXME text was removed during one of the last commits.

        dirk

        brushed added a comment -

        Issue can closed.


          People

          • Assignee:
            Unassigned
            Reporter:
            Florian Holeczek
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development