Jetspeed 2
  1. Jetspeed 2
  2. JS2-837

Attributes template for initial LDAP user/role/group attributes does not accept '=' sign

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.3
    • Fix Version/s: 2.1.3, 2.2.0
    • Component/s: Security
    • Labels:
      None

      Description

      see the LDAP config attributes ''userAttributes" / "roleAttributes" / "groupAttributes". These attributes are used to fill attribute values on new users / roles / groups, and are in the form "attr1Name=attr1Value,attr2Name=attr2Value, ..." .The values don't accept = characters. This should be possible.

      1. JS2-837-v2.patch
        1 kB
        Dennis Dam
      2. JS2-837.patch
        0.9 kB
        Dennis Dam

        Activity

        Hide
        Ate Douma added a comment -

        Patch applied, thanks

        Show
        Ate Douma added a comment - Patch applied, thanks
        Hide
        Dennis Dam added a comment -

        fixed a bug in the bigfix, sorry about that

        Show
        Dennis Dam added a comment - fixed a bug in the bigfix, sorry about that
        Hide
        Dennis Dam added a comment -

        this patch takes the string after the = sign as the attribute value

        Show
        Dennis Dam added a comment - this patch takes the string after the = sign as the attribute value

          People

          • Assignee:
            Ate Douma
            Reporter:
            Dennis Dam
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development