Jetspeed 2
  1. Jetspeed 2
  2. JS2-82

Auto Deploy doesn't release resource

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0-dev/cvs
    • Fix Version/s: 2.0-dev/cvs, 2.0-M2
    • Component/s: None
    • Labels:
      None
    • Environment:
      Windows 2000 and XP, doesn't seem to be a problem on Linux

      Description

      The Auto Deployer doesn't release resources when deploying.
      To reproduce:

      • drop a portlet app War into the deploy directory
      • the Auto Deployer correctly deploys it
      • delete the portlet app War, and it fails since the War file is locked

      I think the jar file isn't being released properly, i.e. close the stream
      I'll try to track this down when I get a few spare moments...(not easy lately)

        Activity

        Ate Douma added a comment -
        David Sean Taylor added a comment -

        Re assigning to Scott as he is working on this issue with his team


          People

          • Assignee:
            Scott T Weaver
            Reporter:
            David Sean Taylor
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development