Jetspeed 2
  1. Jetspeed 2
  2. JS2-572

Maven 2 build requires spring-portlet and spring-beans version

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.1-dev
    • Fix Version/s: 2.1-dev, 2.1
    • Component/s: Project Build
    • Labels:
      None
    • Environment:
      Maven 2.0.4

      Description

      Build fails with the message,

      [0] 'dependencies.dependency.version' is missing for org.springframework:spring-beans
      [1] 'dependencies.dependency.version' is missing for org.springframework:spring-portlet

        Activity

        Hide
        Ate Douma added a comment -

        Closed again now properly recorded against Fix Version 2.1 as well

        Show
        Ate Douma added a comment - Closed again now properly recorded against Fix Version 2.1 as well
        Hide
        Steve Milek added a comment -

        added spring-portlet and spring-beans dependencies and version properties to ./pom.xml - needed by applications/gems

        Show
        Steve Milek added a comment - added spring-portlet and spring-beans dependencies and version properties to ./pom.xml - needed by applications/gems
        Hide
        David Sean Taylor added a comment -

        Steve is going to handle this and try out his new subversion account

        Show
        David Sean Taylor added a comment - Steve is going to handle this and try out his new subversion account
        Hide
        Philip Mark Donaghy added a comment -

        Patch adds version numbers to pom.xml. The maven 2 build is good, much better than maven 1. It's nice to be able to configure in xml but a httpd.conf type directory would be better than putting all in one settings.xml. We use maven 2 in the Andromda project.

        Show
        Philip Mark Donaghy added a comment - Patch adds version numbers to pom.xml. The maven 2 build is good, much better than maven 1. It's nice to be able to configure in xml but a httpd.conf type directory would be better than putting all in one settings.xml. We use maven 2 in the Andromda project.

          People

          • Assignee:
            Steve Milek
            Reporter:
            Philip Mark Donaghy
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development