Jetspeed 2
  1. Jetspeed 2
  2. JS2-519

Concurrency issues due to ServletPortletInvoker being used as singleton

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0-FINAL
    • Fix Version/s: 2.1-dev, 2.1
    • Component/s: Container
    • Labels:
      None
    • Environment:
      Solaris 8, Oracle 9, Java 1.5

      Description

      Was running load tests and found several exceptions that seemed to say that a portlet was being rendered in the wrong fragment window.

      After looking around, I found that the ServletPortletInvoker is configured to NOT be a singleton, but because it is referenced in the constructor of the PortletInvoker singleton it (ServletPortletInvoker) is being used as a singleton.

      Confirmed this behaviour by adding log entry in the constructor and found it was only instantiated once even though several portlets were rendered.

        Activity

        David Sean Taylor added a comment -

        Added a factory around the invokers, configured factory into Spring

        Ate Douma added a comment -

        Closed again now properly recorded against Fix Version 2.1 as well


          People

          • Assignee:
            David Sean Taylor
            Reporter:
            Ethan Adams
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development