Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not a Problem
    • Affects Version/s: 2.1.3, 2.1.4, 2.2.1
    • Fix Version/s: 2.1.4, 2.2.2
    • Component/s: Portlet Registry
    • Labels:
      None
    • Environment:
      org.apache.jetspeed.tools.pamanager.TestPortletApplicationManager unit test case, 2.1.X verified, 2.2.X needs to be checked

      Description

      OJB exceptions appear during parallel PAM unit tests:

      java.lang.RuntimeException: Failed to store node of type 1 for the path /portlet_application/test-pa/portlets/GroupBrowserPortlet/preferences/WindowSize. org.springframework.orm.ojb.OjbOperationException: OJB operation failed; nested exception is org.apache.ojb.broker.PersistenceBrokerException:
      Could not get key value
      ...
      Caused by: org.springframework.orm.ojb.OjbOperationException: OJB operation failed; nested exception is org.apache.ojb.broker.PersistenceBrokerException: Could not get key value
      ...
      Caused by: org.apache.ojb.broker.util.sequence.SequenceManagerException: Can't build new sequence
      ...
      Caused by: org.apache.ojb.broker.OptimisticLockException: Object has been modified by someone else

        Activity

        Randy Watler added a comment -

        Add test case checks for Derby which cannot support parallel concurrent access.

        Randy Watler added a comment -

        Committed revision 929924

        JS2-1130: skip concurrent PAM tests for Derby database.

        Randy Watler added a comment - - edited

        These concurrent DB access errors are successfully handled by the PAM retries, but cannot be filtered from the logs since they are reported by the Digester used to parse portlet.xml files in 2.1.3-POST_RELEASE/2.1.4. 2.2.0+ does not utilize the Digester, so these errors are not logged there.


          People

          • Assignee:
            Randy Watler
            Reporter:
            Randy Watler
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development