Commons JEXL
  1. Commons JEXL
  2. JEXL-109

error when i define a variable named <LITERAL>.<LITERAL>.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None

      Activity

      Henri Biestro added a comment -

      Since it was never possible to do it, this would be a new feature. Besides the fact that no scripting language I know allows this syntax, there is no strong case for it. Thus, wont fix.

      Henri Biestro added a comment -

      Do you have a test case for the kind of expression you'd like to use?
      For instance, something like the following:
      <code>
      public void test109() throws Exception

      { JexlEngine jexl = new JexlEngine(); Object value; JexlContext context = new MapContext(); context.set("foo.bar", 40); value = jexl.createExpression("foo.bar + 2").evaluate(context); assertEquals(42, value); }

      </code>
      If you are really trying to define a variable named "foo.bar.", this is not a bug but an RFE that I'd vote against adding without a use-case.
      Cheers


        People

        • Assignee:
          Unassigned
          Reporter:
          Cristian Lorenzetto
        • Votes:
          0 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development