Commons Jelly
  1. Commons Jelly
  2. JELLY-172

util:properties locks the file forever

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.0
    • Component/s: taglib.util
    • Labels:
      None
    • Environment:

      windows, util-taglib version that comes with maven 1.0.2

      Description

      The following code (taken from a maven script) will always fail:

      <ant:echoproperties destfile="$

      {basedir}/test.properties"/>
      <util:properties file="${basedir}

      /test.properties" var="foo"/>
      <ant:delete file="$

      {basedir}

      /test.properties"/>

      From looking tinto the source, I would guess that the problem is an InputStream which is opened, but never closed.

      The problem definitly appears on windows, can't test on other platforms.

      1. suite.jelly
        8 kB
        Matthias Kerkhoff
      2. PropertiesTag.java
        4 kB
        Matthias Kerkhoff

        Activity

        dion gillard added a comment -

        Committed

        Matthias Kerkhoff added a comment -

        Proposed fix and testcase for JELLY-172.


          People

          • Assignee:
            Unassigned
            Reporter:
            Matthias Kerkhoff
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development