Commons JCS
  1. Commons JCS
  2. JCS-64

Clarification on JCS compatibility nature with JDK

    Details

    • Type: Question Question
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: jcs-1.3
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      Solaris platform with JDK 1.4.2_19

      Description

      Hi ,
      We have an application which uses JCS1.0.Our application is in
      JDK1.4.2_19.We are planning to upgrade to JCS1.3.We would like to clarify
      below few things regarding this JCS compatibility nature.

      1. Is JCS 1.0 compatible with JDK1.4.2_19?. any other issues anyone reported
      with this combination?
      2. What is the compatible JDK version for JCS 1.3 ?
      3. Any recommendations that which JCS version to be used with JDK 1.4.2_19.

      Thanks in advance.

        Activity

        Hide
        Aaron Smuts added a comment -

        JCS 1.3.0 is compatible with JDK's 1.3 and up.

        I recommend using the latest RC build jcs-1.3.3.3-RC. It's compiled under JDK 1.4.2. This tempbuilds have many bug fixes and feature enhancements.

        Show
        Aaron Smuts added a comment - JCS 1.3.0 is compatible with JDK's 1.3 and up. I recommend using the latest RC build jcs-1.3.3.3-RC. It's compiled under JDK 1.4.2. This tempbuilds have many bug fixes and feature enhancements.
        Hide
        senthilmohan added a comment -

        Hi Aaron,

        Thank you very much for your reply. Would it be any problem if we keep
        JCS1.0 with JDK1.4.2_19.

        Regards,
        Senthil.

        Show
        senthilmohan added a comment - Hi Aaron, Thank you very much for your reply. Would it be any problem if we keep JCS1.0 with JDK1.4.2_19. Regards, Senthil.
        Hide
        Aaron Smuts added a comment -

        JDK's are almost completely backward compatible. I can't think of any problems. But you shouldn't use such an old version. There have been 5 years of bug fixes and improvements since the 1.0 temp build.

        Show
        Aaron Smuts added a comment - JDK's are almost completely backward compatible. I can't think of any problems. But you shouldn't use such an old version. There have been 5 years of bug fixes and improvements since the 1.0 temp build.
        Hide
        senthilmohan added a comment -

        Thank you Aaron for clarifying.

        Regards,
        Senthil.

        Show
        senthilmohan added a comment - Thank you Aaron for clarifying. Regards, Senthil.

          People

          • Assignee:
            Aaron Smuts
            Reporter:
            senthilmohan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 24h
              24h
              Remaining:
              Remaining Estimate - 24h
              24h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development