Jackrabbit Site
  1. Jackrabbit Site
  2. JCRSITE-10

Parent pom requires Maven 2.0.9 or higher

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: parent 2
    • Fix Version/s: parent 3
    • Component/s: parent
    • Labels:
      None

      Description

      The javadoc plugin specified in the newly released parent pom version 2 only works with Maven 2.0.9 or higher. We should either downgrade the plugin to work with earlier Maven versions, or upgrade the minimum Maven version declared in the POM to 2.0.9.

      I started an email thread on dev@ to decide what to do. This issue will be used to track that the decision gets implemented.

        Activity

        Hide
        Jukka Zitting added a comment -

        The consensus seems to be that requiring 2.0.9 as the minimum version is fine.

        In revision 742383 I updated the parent POM to specify 2.0.9 as a prerequisite. Resolving as Fixed.

        Show
        Jukka Zitting added a comment - The consensus seems to be that requiring 2.0.9 as the minimum version is fine. In revision 742383 I updated the parent POM to specify 2.0.9 as a prerequisite. Resolving as Fixed.

          People

          • Assignee:
            Jukka Zitting
            Reporter:
            Jukka Zitting
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development