Jackrabbit Content Repository
  1. Jackrabbit Content Repository
  2. JCR-976

Misleading exception message when re-index fails

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.4
    • Component/s: indexing, jackrabbit-core
    • Labels:
      None

      Description

      E.g. the log may say:

      19.06.2007 11:25:42 ERROR RepositoryImpl: Failed to initialize workspace 'default' (RepositoryImpl.java, line 382)
      javax.jcr.RepositoryException: Error indexing root node: 10022d38-c449-4751-b8f0-9d07ac45ead5:
      [...]

      The mentioned uuid is not the root node and the root cause is missing.

        Activity

        Marcel Reutegger created issue -
        Marcel Reutegger added a comment -

        Fixed in revision: 549117

        Marcel Reutegger made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 1.4 [ 12312447 ]
        Resolution Fixed [ 1 ]
        Jukka Zitting made changes -
        Affects Version/s 1.1.1 [ 12312099 ]
        Affects Version/s 1.2.1 [ 12312100 ]
        Affects Version/s 1.1 [ 12310346 ]
        Affects Version/s 1.0 [ 12310154 ]
        Component/s jackrabbit-core [ 12310114 ]
        Affects Version/s 1.2.2 [ 12312228 ]
        Affects Version/s 1.0.1 [ 12310345 ]
        Affects Version/s 1.3 [ 12312229 ]
        Affects Version/s 1.2.3 [ 12312329 ]
        Jukka Zitting made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Jukka Zitting made changes -
        Workflow jira [ 12406689 ] no-reopen-closed, patch-avail [ 12468857 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Marcel Reutegger
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development