Uploaded image for project: 'Jackrabbit Content Repository'
  1. Jackrabbit Content Repository
  2. JCR-4036

Upgrade to latest lucene-core

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 2.13.3
    • Fix Version/s: None
    • Component/s: jackrabbit-core
    • Labels:
      None

      Description

      jackrabbit-core depends on lucene-core 3.6.0 (from Apr 2012). The current version of lucene-core is 6.2.1 from Sep 2016.

      When using jackrabbit and lucene (or hibernate-search or others) in the same project one is stuck to very old versions of these projects (and their bugs).

      Please update the dependency to one of the latest lucene-core versions - e.g. 5.5.2 as used by hibernate-search 5.6.0.Beta2
      Or define a version range when jackrabbit runs with several versions of lucene-core

        Attachments

        Issue Links

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              Sebastian.Dietrich Sebastian Dietrich

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment