Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.2, 2.3
    • Fix Version/s: None
    • Component/s: jackrabbit-jcr-server
    • Labels:
      None

      Description

      Currently flash videos are stored with a mimetype of application/octet-stream because the .flv extension is not recognized. This leads to subsequent processes (e.g. video workflows, thumbnail extraction, etc.) ignoring these FLV files completely. Could you thus add the following line to the jackrabbit-jcr-server/src/main/resources/org/apache/jackrabbit/server/io/mimetypes.properties file:
      flv=video/x-flv

        Activity

        Jukka Zitting added a comment -

        Works for me:

        $ curl -v -u admin:admin -T testFLV.flv http://localhost:8080/repository/default/test.flv
        > PUT /repository/default/test.flv HTTP/1.1
        > Authorization: Basic YWRtaW46YWRtaW4=
        > User-Agent: curl/7.21.0 [...]
        > Host: localhost:8080
        > Accept: /
        > Content-Length: 90580
        > Expect: 100-continue
        >
        < HTTP/1.1 100 Continue
        < HTTP/1.1 201 Created
        < Content-Length: 0
        < Server: Jetty(6.1.x)
        <

        $ curl -v -u admin:admin http://localhost:8080/repository/default/test.flv -o /dev/null
        > GET /repository/default/test.flv HTTP/1.1
        > Authorization: Basic YWRtaW46YWRtaW4=
        > User-Agent: curl/7.21.0 [...]
        > Host: localhost:8080
        > Accept: /
        >
        < HTTP/1.1 200 OK
        < ETag: "90580-1321984290570"
        < Content-Length: 90580
        < Last-Modified: Tue, 22 Nov 2011 17:51:30 GMT
        < Content-Type: video/x-flv
        < Server: Jetty(6.1.x)
        <

        Note the Content-Type: video/x-flv in the response headers.

        Note that since Jackrabbit 2.0 and JCR-2334 the type of incoming documents is detected using the type database in Apache Tika. The mimetypes.properties file found in jackrabbit-jcr-server is no longer used for anything, so I removed it and related references in revision 1205114.

        Mike Pfaff added a comment -

        The video was likely uploaded with WebDAV. Looking at JCR-2334 i am a bit confused: Is the Tika-based lookup also done for WebDAV (The WebDAV on customer box is mounted at http://server:4502/ )?

        Alexander Klimetschek added a comment -

        If you say it's the webdav mounted under http://server:4502/, I guess this is a Sling box and using the Sling webdav. This has its own mime type mapping config.

        angela added a comment -

        please note that there is no "the Sling webdav" implementation but it's in fact is just a thin wrapper around the one exposed by
        jackrabbit. regarding the mime type mapping: afaik this has been addressed with SLING-1059

        Alexander Klimetschek added a comment -

        > please note that there is no "the Sling webdav" implementation but it's in fact is just a thin wrapper around the one exposed by jackrabbit

        Yes, but in this case sling webdav has a notable difference to the standard jackrabbit webdav servlet, even if it is just the configuration


          People

          • Assignee:
            Unassigned
            Reporter:
            Mike Pfaff
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development