Uploaded image for project: 'jclouds'
  1. jclouds
  2. JCLOUDS-897

jclouds breaks with guice 4.0 because rocoto is evil

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.9.0
    • Fix Version/s: 2.0.0
    • Component/s: jclouds-core
    • Labels:
      None

      Description

      Rocoto is a horrible, horrible library. It uses com.google.inject.internal.util.$Preconditions, which you quite obviously should not do. This has been a known issue for years (https://github.com/99soft/rocoto/issues/7), but has not been fixed yet. In fact, the library is completely un-maintained with no commits since 2012. I would love it if we could get rid of this dependency since pulling it in is breaking my project.

        Attachments

          Activity

            People

            • Assignee:
              nacx Ignasi Barrera
              Reporter:
              chengas123 Ben McCann
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: