Uploaded image for project: 'jclouds'
  1. jclouds
  2. JCLOUDS-1233

Bump JAX-RS spec

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0
    • Fix Version/s: 2.1.0
    • Component/s: jclouds-core
    • Labels:
      None

      Description

      Looking at https://github.com/jclouds/jclouds/blob/master/core/pom.xml, jclouds-core uses:

          <dependency>
            <groupId>javax.ws.rs</groupId>
            <artifactId>jsr311-api</artifactId>
            <version>1.1.1</version>
          </dependency>
      

      which means that jclouds-core is using JAX-RS 1.x, while we may want to use

      <dependency>
            <groupId>javax.ws.rs</groupId>
            <artifactId>javax.ws.rs-api</artifactId>
            <version>2.0.1</version>
          </dependency>
      

      as javax.ws.rs-api is the official spec jar for the JAX-RS 2.x

      See http://stackoverflow.com/questions/32106428/jaxrs-api-vs-jsr311-api-vs-javax-ws-rs-api-vs-jersey-core

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                andreaturli Andrea Turli
                Reporter:
                andreaturli Andrea Turli
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: