James Server
  1. James Server
  2. JAMES-911

Migrate from Avalon to something else

    Details

    • Type: New Feature New Feature
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: Trunk
    • Fix Version/s: 3.0-M1
    • Component/s: James Core
    • Labels:
      None

      Description

      Reasons:

      1. Apache Avalon project was closed in 2004. There are no software projects without bugs. And Avalon bugs are not resolved for years!
      2. You can't find any documentation about Apache Avalon!

      I am a java developer and I was interested in Apache James project and even was going to start contributing some code. But when I started to investigate more about James I could not understand how you could use something that is years old, have no active maintenance and development and even don't have any public documentation. I even can't find any details about what exactly Avalon does! I am absolutely positive that there are a lot of modern alternatives to some Avalon. From the other point of view if Avalon was something good it would not have been closed. Avalon is closed and this means that nobody was interested in it and nobody really needed it.

      If you want to attract some non payed developers to your open source project it should be interesting for them to work with your project. But there are references from your site to http://avalon.apache.org/ and when new developers see that site it does not encourage him/her to start to dig deeper.

      Avalon is dead. You need to move forward!

        Activity

        Norman Maurer added a comment -

        We now use spring to support JSR250 dependency injections and so no avalon is needed for all this stuff. The only

        Bernd Fondermann added a comment -

        I feel very much like you do.

        Yet, what you are describing is not a bug, and it's not critical. It's legacy.
        The code and doc is there, it's in Apache Excalibur, and we can work with it. Not that we want to, but, again, it's not critical.

        We discuss these things on our developer mailing list, not on the bug tracker.
        You are very welcome to join us there thinking about how to move forward, JIRA just isn't the right place.

        Please also note we took steps to overcome our architectural crisis. One is the spring-deployment in trunk.
        Others are in discussion, longing for contributors to start working on them.
        I encourage you to browse our server-dev mailing list archive to catch up with these discussions.

        Also, please be more concrete and specific in the bug tracker in the future. Thanks!


          People

          • Assignee:
            Norman Maurer
            Reporter:
            Serhiy
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development