Uploaded image for project: 'James Server'
  1. James Server
  2. JAMES-613

Define a new version for Mailet API and update James.java to return the new version.

    Details

      Description

      We should update mailet api version to 2.3.0 and also return 3 from the James.getMinorVersion.
      In 2.2.0 we returned 2.1.0: not sure wether 2.1.0 and 2.2.0 bundled the same mailet apis or it is a mistake, btw imo we should use 2.3.0 for the updated mailet apis because it does not make sense to have james 2.3.0 and mailet apis 2.2.0 as we still release both as a single package (it would only increase confusion).

        Activity

        Hide
        bago Stefano Bagnara added a comment -

        Changed 2.3 branch container to return 2.3 as mailet api version.
        Temporarily changed trunk to return 2.4 (to avoid forgetting this as 2.1).

        Show
        bago Stefano Bagnara added a comment - Changed 2.3 branch container to return 2.3 as mailet api version. Temporarily changed trunk to return 2.4 (to avoid forgetting this as 2.1).
        Hide
        danny@apache.org Danny Angus added a comment -

        Closing issue fixed in released version.

        Show
        danny@apache.org Danny Angus added a comment - Closing issue fixed in released version.

          People

          • Assignee:
            bago Stefano Bagnara
            Reporter:
            bago Stefano Bagnara
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development