Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.3.0, 3.0.0
    • Fix Version/s: 2.3.0
    • Labels:
      None

      Description

      If user A is an alias of user B ( or viceversa - remote manager help is misleading) messages sent to A have to go (and were going) to B's inbox. Now it ends in A's inbox, that should not even exist.
      The problem has been found by me using both "file" and "db" repositories under 2.3.0b2, but I expect it to occur also under 3.0.

        Activity

        norman Norman Maurer added a comment -

        After some debug it seems that the UsersRepositoryAliasingForwarding Mailet get not called. No time now to investigate time on this now

        noel Noel J. Bergman added a comment -

        Just to keep people following this in the loop, Norman observed on IM that "The problem is that ((JamesUser) user).getAliasing() return false."

        noel Noel J. Bergman added a comment -

        Committed fix to both trunk and v2.3 branch. The check for an aliased name had the wrong polarity.

        vincenzo Vincenzo Gianferrari Pini added a comment -

        It works now for me. Thanks to all of the team for the work.
        I'll test 2.3.0b2 again in production on the weekend of July 22-23.

        danny@apache.org Danny Angus added a comment -

        Closing issue fixed in released version.


          People

          • Assignee:
            norman Norman Maurer
            Reporter:
            vincenzo Vincenzo Gianferrari Pini
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development