Uploaded image for project: 'James Server'
  1. James Server
  2. JAMES-538

Original headers are lost when trying to alter headers of a cloned message

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.3.0, 3.0.0
    • Fix Version/s: 2.3.0
    • Component/s: None
    • Labels:
      None

      Description

      This has been reported by Lauren Rouvet first:
      --------------------
      Hi,

      I'm testing James 2.3a4 since 15 days... It seems working fine

      But on one server, I get a strange problem:
      I get SOME (not all the time ???) emails without subjet, sender and reciepients

      I send a message TEST from my PC

      --------------------------------------
      > From - Thu Jun 15 00:35:26 2006
      X-Mozilla-Status: 0001
      X-Mozilla-Status2: 00800000
      Message-ID: <44908F2D.90400@rouvet.com>
      Date: Thu, 15 Jun 2006 00:35:25 +0200
      From: Laurent Rouvet <laurent@rouvet.com>
      User-Agent: Mozilla Thunderbird 1.0.2 (Windows/20050317)
      X-Accept-Language: en-us, en
      MIME-Version: 1.0
      To: Laurent Rouvet <laurent@rouvet.com>
      Subject: test
      Content-Type: text/plain; charset=ISO-8859-1; format=flowed
      Content-Transfer-Encoding: 7bit

      test
      --------------------------------------

      And I received it back (via pop3) without the subject, to, from ... :

      --------------------------------------
      Message-ID: <1623128.81150324881913.JavaMail.root@dsa2331.ayzo.net>

      MIME-Version: 1.0
      Content-Type: text/plain; charset=us-ascii
      Content-Transfer-Encoding: 7bit

      TEST

      --------------------------------------

      It's probably my config.xml... but it work fine with my oldest James... ?
      I wonder if my issue is not with the Redirect Mailet. I'm using it like that:

      <mailet match="UserIs=laurent" class="Redirect">
      <recipients>laurent.rouvet@gmail.com</recipients>
      <inline>unaltered</inline>
      <passThrough>TRUE</passThrough>
      <static>TRUE</static>
      </mailet>
      <mailet match="RecipientIsLocal" class="LocalDelivery"/>

      On Gmail my message are ok, but via POP3 it's not...
      moreover it's quite difficulte to test because on 3 test it works 1 or 2!??

      Any clue ?

      Thanks,

      Laurent Rouvet
      ------

      Norman Maurer reproduced this problem, too.

        Activity

        norman Norman Maurer added a comment -

        Just test your latest commit to see if it fix it. And yes you did it, our problems with lost headers are gone.
        So i think you can close it.

        Thx Stefano

        danny@apache.org Danny Angus added a comment -

        Closing issue fixed in released version.


          People

          • Assignee:
            bago Stefano Bagnara
            Reporter:
            bago Stefano Bagnara
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development