Uploaded image for project: 'James Server'
  1. James Server
  2. JAMES-522

Having the ClamAVScan mailet configured, but clamd unavailable when JAMES starts, keeps JAMES from starting.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 2.3.0
    • Fix Version/s: 2.3.0
    • Labels:
      None

      Description

      If JAMES attempts to start, ClamAVScan is configured, and clamd is not running, ClamAVScan.init() will throw an exception, terminating JAMES entirely. This can be seen in $

      {james}

      /logs/phoenix.log where the maxPings error will appear, and the spoolmanager component will be shown as failing.

      I'm marking this as minor since there is a work around, biut actually, I consider it a more major error.

        Activity

        noel Noel J. Bergman added a comment -

        In the mailet config, adding <maxPings>0</maxPings> will disable the check, and the error, so this is arguably a "trivial" error. Still, it presents a good example of where we can improve retry with queuing. And we really should provide a better error message to help admins, since the default is to fail.

        vincenzo Vincenzo Gianferrari Pini added a comment -

        I would keep things as now, because this was the intended behaviour. If <maxPings>n</maxPings>, with n > 0, the desired behaviour is to delay the startup of James until clamd is up and running, without allowing any message to flow without an anti-virus check. Such situation could arise with a server startup, where clamd could take longer than james to start. If after some time clamd has not yet started, James must fail and the administrator shall intervene to fix clamd.
        If I don't want such "safe" behaviour, I can set <maxPings>0</maxPings> as you did.
        BTW, I'm changing config.xml to have a commented invocation of ClamAVScan (plus some other enhancements).

        danny@apache.org Danny Angus added a comment -

        Closing issue fixed in released version.


          People

          • Assignee:
            norman Norman Maurer
            Reporter:
            noel Noel J. Bergman
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development