Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.3.0
    • Fix Version/s: 2.3.0
    • Component/s: None
    • Labels:
      None

      Description

      We should rename AddHeader and AddHeaderHandler to represent the function.

        Activity

        Hide
        norman Norman Maurer added a comment -

        when working on junit test for AddHeaderHandler i notice that the
        AddHeaderHandler use setHeader(String name, String value); . So it not
        add a header, it set a header. This is not what i espected when i read
        the Handlername.

        So for me are 2 solutions:

        1. Rename the AddHeaderHandler to SetHeaderHandler
        2. use addHeader(String name, String value) instand of setHeader(String
        name, String value)

        i prefer the first. What the you think ?

        Show
        norman Norman Maurer added a comment - when working on junit test for AddHeaderHandler i notice that the AddHeaderHandler use setHeader(String name, String value); . So it not add a header, it set a header. This is not what i espected when i read the Handlername. So for me are 2 solutions: 1. Rename the AddHeaderHandler to SetHeaderHandler 2. use addHeader(String name, String value) instand of setHeader(String name, String value) i prefer the first. What the you think ?
        Hide
        norman Norman Maurer added a comment -

        Maybe we should rename the AddHeader to SetHeader and add new Method
        which extend on this named AddHeader. This method should be marked as
        deprected. Then we can later remove it.

        Same to the handler.

        What you guys think ?

        Show
        norman Norman Maurer added a comment - Maybe we should rename the AddHeader to SetHeader and add new Method which extend on this named AddHeader. This method should be marked as deprected. Then we can later remove it. Same to the handler. What you guys think ?
        Hide
        norman Norman Maurer added a comment -

        To clarify my position:

        +1 to deprecate the AddHeader and add a new Set*Header
        +0.6 to name it SetMimeHeader
        +0.4 to name it SetRfc822Header (most correct, but less intelligible
        to non techies)
        +0.2 to name it SetHeader

        Furthermore

        +1 to do that in the 2.3 branch and remove AddHeader from the trunk

        Stefano

        Show
        norman Norman Maurer added a comment - To clarify my position: +1 to deprecate the AddHeader and add a new Set*Header +0.6 to name it SetMimeHeader +0.4 to name it SetRfc822Header (most correct, but less intelligible to non techies) +0.2 to name it SetHeader Furthermore +1 to do that in the 2.3 branch and remove AddHeader from the trunk Stefano
        Hide
        norman Norman Maurer added a comment -

        Should we merge it in the branch so we can remove the old classes in 2.4/3.0 ?

        Show
        norman Norman Maurer added a comment - Should we merge it in the branch so we can remove the old classes in 2.4/3.0 ?
        Hide
        danny@apache.org Danny Angus added a comment -

        Closing issue fixed in released version.

        Show
        danny@apache.org Danny Angus added a comment - Closing issue fixed in released version.

          People

          • Assignee:
            norman Norman Maurer
            Reporter:
            norman Norman Maurer
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development