James Server
  1. James Server
  2. JAMES-456

AddFooter mailet javax.mail.internet.ParseException

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.3.0
    • Labels:
      None

      Description

      I just found a javax.mail.internet.ParseException in my logs. Im not 100% sure that this is a bug:

      15/03/06 10:44:24 ERROR spoolmanager: Exception in processor <excubator>
      javax.mail.internet.ParseException
      at javax.mail.internet.ParameterList.<init>(ParameterList.java:81)
      at javax.mail.internet.ContentType.<init>(ContentType.java:82)
      at javax.mail.internet.MimeBodyPart.updateHeaders(MimeBodyPart.java:1105)
      at javax.mail.internet.MimeBodyPart.updateHeaders(MimeBodyPart.java:863)
      at javax.mail.internet.MimeMultipart.updateHeaders(MimeMultipart.java:23
      9)
      at javax.mail.internet.MimeBodyPart.updateHeaders(MimeBodyPart.java:1111)
      at javax.mail.internet.MimeMessage.updateHeaders(MimeMessage.java:1927)
      at javax.mail.internet.MimeMessage.saveChanges(MimeMessage.java:1908)
      at org.apache.james.core.MimeMessageWrapper.saveChanges(MimeMessageWrapper.java:883)
      at org.apache.james.core.MimeMessageCopyOnWriteProxy.saveChanges(MimeMessageCopyOnWriteProxy.java:711)
      at org.apache.james.transport.mailets.AddFooter.service(AddFooter.java:66)
      at de.byteaction.excubator.james.transport.mailets.AddFooterFromAttribute.service(AddFooterFromAttribute.java:59)
      at org.apache.james.transport.LinearProcessor.service(LinearProcessor.java:414)
      at org.apache.james.transport.JamesSpoolManager.process(JamesSpoolManager.java:397)
      at org.apache.james.transport.JamesSpoolManager.run(JamesSpoolManager.java:306)
      at java.lang.Thread.run(Thread.java:595)

      1. exception.dump
        4 kB
        Norman Maurer
      2. exception.dump
        4 kB
        Norman Maurer

        Activity

        Mark Thomas made changes -
        Workflow Default workflow, editable Closed status [ 12565968 ] jira [ 12581967 ]
        Mark Thomas made changes -
        Workflow jira [ 12352033 ] Default workflow, editable Closed status [ 12565968 ]
        Norman Maurer made changes -
        Fix Version/s 2.4.0 [ 12311645 ]
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Closed [ 6 ]
        Fix Version/s 2.3.0a3 [ 12311010 ]
        Norman Maurer added a comment -

        I don't see this behavior for ages now... I close it.

        Stefano Bagnara made changes -
        Fix Version/s 2.4.0 [ 12311645 ]
        Stefano Bagnara made changes -
        Assignee Stefano Bagnara [ bago ]
        Stefano Bagnara added a comment -

        The message you attached has the body of a multipart message but has no content-type.
        Your AddFooter is probably different from mine because line numbers in your stacktrace don't match.
        Can you reproduce the problem in a test?
        Look at the AddFooterTest.java source code to see how we run unit tests for AddFooter.

        Norman Maurer made changes -
        Attachment exception.dump [ 12324413 ]
        Norman Maurer added a comment -

        I just did this:
        select * from deadletter where error_message IS NULL order by last_updated desc limit 1 into outfile '/tmp/exception.dump';

        in the file is the output.

        Norman Maurer made changes -
        Field Original Value New Value
        Attachment exception.dump [ 12324412 ]
        Norman Maurer added a comment -

        Here is such a message that cause this exception..

        I just did a : select * from deadletter where error_message IS NULL order by last_updated desc limit 1 into outfile '/tmp/exception.dump;

        Norman Maurer added a comment -

        not yet.. I will attach one if i see one again in the logs and deadletter table.

        Stefano Bagnara added a comment -

        Can you find a mail to reproduce the issue?

        Norman Maurer created issue -

          People

          • Assignee:
            Stefano Bagnara
            Reporter:
            Norman Maurer
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development