Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Invalid
    • Affects Version/s: 2.3.0
    • Fix Version/s: 2.3.0
    • Component/s: None
    • Labels:
      None

      Description

      All the mails from clamav-virusdb@lists.clamav.net are broken after getting through james..

      maybe thats a problem with the smime ?

      Return-Path: <clamav-virusdb-bounces@lists.clamav.net>
      Delivered-To: nm@spam-box.de
      Received: (qmail 828 invoked by uid 89); 3 Mar 2006 16:24:27 -0000
      Received: from localhost (HELO mail.guden.ath.cx) (127.0.0.1) by
      guden.ath.cx with SMTP; 3 Mar 2006 16:24:27 -0000
      Return-Path: null
      Received: from hiphopcorner.de ([62.75.159.71]) by mail.guden.ath.cx (JAMES
      SMTP Server 2.3-dev) with SMTP ID 168 for <nm@spam-box.de>; Fri, 3 Mar 2006
      17:24:26 +0100 (CET)
      Received: (qmail 13408 invoked from network); 3 Mar 2006 16:23:46 -0000
      Received: from aj.catt.com (64.18.103.6) by mail.spam-box.de with SMTP; 3
      Mar 2006 16:23:46 -0000
      Received: from aj.catt.com (localhost [127.0.0.1]) by aj.catt.com (Postfix)
      with ESMTP id 7D16F156190; Fri, 3 Mar 2006 11:22:24 -0500 (EST)
      Received: from mail.softcom.dk (mail.softcom.dk [217.157.23.229]) by
      aj.catt.com (Postfix) with ESMTP id 0A4A910E221 for
      <clamav-virusdb@lists.clamav.net>; Fri, 3 Mar 2006 11:22:14 -0500 (EST)
      Received: from [172.29.10.79] ([217.157.23.228]) by mail.softcom.dk over
      TLS secured channel with Microsoft SMTPSVC(6.0.3790.1830); Fri, 3 Mar 2006
      17:22:12 +0100
      Message-ID: <5439183.1141403067298.JavaMail.root@Fileserver>
      Date: Fri, 03 Mar 2006 17:19:41 +0100
      From: Diego d'Ambra <da@softcom.dk>
      Organization: SoftCom Solutions
      User-Agent: Thunderbird 1.5 (Windows/20051201)
      MIME-Version: 1.0
      To: ClamAV virus update <clamav-virusdb@lists.clamav.net>
      Subject: [Clamav-virusdb] Update (daily: 1313)
      X-OriginalArrivalTime: 03 Mar 2006 16:22:12.0413 (UTC)
      FILETIME=[A09096D0:01C63EDE]
      X-BeenThere: clamav-virusdb@lists.clamav.net
      X-Mailman-Version: 2.1.5
      Precedence: list
      Reply-To: noreply@clamav.net
      List-Id: ClamAV VirusDB announcements <clamav-virusdb.lists.clamav.net>
      List-Unsubscribe:
      <http://lists.clamav.net/cgi-bin/mailman/listinfo/clamav-virusdb>,
      <clamav-virusdb-request@lists.clamav.net?subject=unsubscribe>
      List-Post: <clamav-virusdb@lists.clamav.net>
      List-Help: <clamav-virusdb-request@lists.clamav.net?subject=help>
      List-Subscribe:
      <http://lists.clamav.net/cgi-bin/mailman/listinfo/clamav-virusdb>,
      <clamav-virusdb-request@lists.clamav.net?subject=subscribe>
      Sender: clamav-virusdb-bounces@lists.clamav.net
      Errors-To: clamav-virusdb-bounces@lists.clamav.net
      X-EXCUBATOR-User: nm@spam-box.de
      X-EXCUBATOR-Domain: spam-box.de
      X-EXCUBATOR-Infected: false
      X-EXCUBATOR-Processed: Fri Mar 3 17 24 27 2006
      X-EXCUBATOR-Signature: 2,44086dbb8151873720728
      X-EXCUBATOR-Improbability: 1 in 138 chance of being spam
      X-EXCUBATOR-Result: Whitelisted
      X-EXCUBATOR-Probability: 0.0000
      X-EXCUBATOR-Confidence: 0.5786
      Content-Transfer-Encoding: 7bit
      X-Evolution-Source: imap://nm%40spam-box.de@guden.ath.cx/

      --===============1138503253==
      Content-Type: multipart/signed; protocol="application/x-pkcs7-signature";
      micalg=sha1; boundary="------------ms010105030304030406070606"

      This is a cryptographically signed message in MIME format.

      --------------ms010105030304030406070606
      Content-Type: text/plain; charset=ISO-8859-1; format=flowed
      Content-Transfer-Encoding: 7bit

      ClamAV database updated (2006-Mar-03 16:19 +0000): daily.cvd
      version: 1313

      Submission: n/a
      Sender: Diego d'Ambra
      Added: JS.Feebs.U

      Submission: n/a
      Sender: Diego d'Ambra
      Added: JS.Feebs.V

      Best regards,
      Diego d'Ambra

      --------------ms010105030304030406070606
      Content-Type: application/x-pkcs7-signature; name="smime.p7s"
      Content-Transfer-Encoding: base64
      Content-Disposition: attachment; filename="smime.p7s"
      Content-Description: S/MIME Cryptographic Signature

      MIAGCSqGSIb3DQEHAqCAMIACAQExCzAJBgUrDgMCGgUAMIAGCSqGSIb3DQEHAQAAoIIIGTCC
      AmcwggHQoAMCAQICEEM9Wita6CAfQYVKINelroQwDQYJKoZIhvcNAQEEBQAwYjELMAkGA1UE
      BhMCWkExJTAjBgNVBAoTHFRoYXd0ZSBDb25zdWx0aW5nIChQdHkpIEx0ZC4xLDAqBgNVBAMT
      I1RoYXd0ZSBQZXJzb25hbCBGcmVlbWFpbCBJc3N1aW5nIENBMB4XDTA2MDIyNjA5MTQzNVoX
      DTA3MDIyNjA5MTQzNVowVjEPMA0GA1UEBBMGRGFtYnJhMQ4wDAYDVQQqEwVEaWVnbzEVMBMG
      A1UEAxMMRGllZ28gRGFtYnJhMRwwGgYJKoZIhvcNAQkBFg1kYUBzb2Z0Y29tLmRrMIGfMA0G
      CSqGSIb3DQEBAQUAA4GNADCBiQKBgQCpfa1zpIkPWA08QG0RtEAv/5T1RuA4zS2rDui9IRcP
      MnAwudzO6BNsp2zGABFassvL5PYizJ0/RF9Yes+3n2lvAvsQk9E3AllDKn4s55u2vvNGSo5a
      +5uACCORLTetRjSms67kUGfd2nUPUGaQrysWJ3fuPuvRmCnta+GhA/FkLQIDAQABoyowKDAY
      BgNVHREEETAPgQ1kYUBzb2Z0Y29tLmRrMAwGA1UdEwEB/wQCMAAwDQYJKoZIhvcNAQEEBQAD
      gYEAieTdhCwyKXUPqyUaBiancIch1ZdWaSOWfvx1uLolDqYq/oScn8YNajSIPCitKVyAOu4J
      ePtrUCeu+y70Z+LfwK556xjVv2RjiDsSk6I07eOj/FCsBAa9ymJVd9qPFhGG6q9nxo2LXqH9
      e9vwBrgo5ROyFmtEdSyLfupmP8e83lEwggJnMIIB0KADAgECAhBDPVorWuggH0GFSiDXpa6E
      MA0GCSqGSIb3DQEBBAUAMGIxCzAJBgNVBAYTAlpBMSUwIwYDVQQKExxUaGF3dGUgQ29uc3Vs
      dGluZyAoUHR5KSBMdGQuMSwwKgYDVQQDEyNUaGF3dGUgUGVyc29uYWwgRnJlZW1haWwgSXNz
      dWluZyBDQTAeFw0wNjAyMjYwOTE0MzVaFw0wNzAyMjYwOTE0MzVaMFYxDzANBgNVBAQTBkRh
      bWJyYTEOMAwGA1UEKhMFRGllZ28xFTATBgNVBAMTDERpZWdvIERhbWJyYTEcMBoGCSqGSIb3
      DQEJARYNZGFAc29mdGNvbS5kazCBnzANBgkqhkiG9w0BAQEFAAOBjQAwgYkCgYEAqX2tc6SJ
      D1gNPEBtEbRAL/+U9UbgOM0tqw7ovSEXDzJwMLnczugTbKdsxgARWrLLy+T2IsydP0RfWHrP
      t59pbwL7EJPRNwJZQyp+LOebtr7zRkqOWvubgAgjkS03rUY0prOu5FBn3dp1D1BmkK8rFid3
      7j7r0Zgp7WvhoQPxZC0CAwEAAaMqMCgwGAYDVR0RBBEwD4ENZGFAc29mdGNvbS5kazAMBgNV
      HRMBAf8EAjAAMA0GCSqGSIb3DQEBBAUAA4GBAInk3YQsMil1D6slGgYmp3CHIdWXVmkjln78
      dbi6JQ6mKv6EnJ/GDWo0iDworSlcgDruCXj7a1Anrvsu9Gfi38CueesY1b9kY4g7EpOiNO3j
      o/xQrAQGvcpiVXfajxYRhuqvZ8aNi16h/Xvb8Aa4KOUTshZrRHUsi37qZj/HvN5RMIIDPzCC
      AqigAwIBAgIBDTANBgkqhkiG9w0BAQUFADCB0TELMAkGA1UEBhMCWkExFTATBgNVBAgTDFdl
      c3Rlcm4gQ2FwZTESMBAGA1UEBxMJQ2FwZSBUb3duMRowGAYDVQQKExFUaGF3dGUgQ29uc3Vs
      dGluZzEoMCYGA1UECxMfQ2VydGlmaWNhdGlvbiBTZXJ2aWNlcyBEaXZpc2lvbjEkMCIGA1UE
      AxMbVGhhd3RlIFBlcnNvbmFsIEZyZWVtYWlsIENBMSswKQYJKoZIhvcNAQkBFhxwZXJzb25h
      bC1mcmVlbWFpbEB0aGF3dGUuY29tMB4XDTAzMDcxNzAwMDAwMFoXDTEzMDcxNjIzNTk1OVow
      YjELMAkGA1UEBhMCWkExJTAjBgNVBAoTHFRoYXd0ZSBDb25zdWx0aW5nIChQdHkpIEx0ZC4x
      LDAqBgNVBAMTI1RoYXd0ZSBQZXJzb25hbCBGcmVlbWFpbCBJc3N1aW5nIENBMIGfMA0GCSqG
      SIb3DQEBAQUAA4GNADCBiQKBgQDEpjxVc1X7TrnKmVoeaMB1BHCd3+n/ox7svc31W/Iadr1/
      DDph8r9RzgHU5VAKMNcCY1osiRVwjt3J8CuFWqo/cVbLrzwLB+fxH5E2JCoTzyvV84J3PQO+
      K/67GD4Hv0CAAmTXp6a7n2XRxSpUhQ9IBH+nttE8YQRAHmQZcmC3+wIDAQABo4GUMIGRMBIG
      A1UdEwEB/wQIMAYBAf8CAQAwQwYDVR0fBDwwOjA4oDagNIYyaHR0cDovL2NybC50aGF3dGUu
      Y29tL1RoYXd0ZVBlcnNvbmFsRnJlZW1haWxDQS5jcmwwCwYDVR0PBAQDAgEGMCkGA1UdEQQi
      MCCkHjAcMRowGAYDVQQDExFQcml2YXRlTGFiZWwyLTEzODANBgkqhkiG9w0BAQUFAAOBgQBI
      jNFQg+oLLswNo2asZw9/r6y+whehQ5aUnX9MIbj4Nh+qLZ82L8D0HFAgk3A8/a3hYWLD2ToZ
      foSxmRsAxRoLgnSeJVCUYsfbJ3FXJY3dqZw5jowgT2Vfldr394fWxghOrvbqNOUQGls1TXfj
      ViF4gtwhGTXeJLHTHUb/XV9lTzGCAuMwggLfAgEBMHYwYjELMAkGA1UEBhMCWkExJTAjBgNV
      BAoTHFRoYXd0ZSBDb25zdWx0aW5nIChQdHkpIEx0ZC4xLDAqBgNVBAMTI1RoYXd0ZSBQZXJz
      b25hbCBGcmVlbWFpbCBJc3N1aW5nIENBAhBDPVorWuggH0GFSiDXpa6EMAkGBSsOAwIaBQCg
      ggHDMBgGCSqGSIb3DQEJAzELBgkqhkiG9w0BBwEwHAYJKoZIhvcNAQkFMQ8XDTA2MDMwMzE2
      MTk0MVowIwYJKoZIhvcNAQkEMRYEFAWga8ZnErEGtAa57l752pTz631FMFIGCSqGSIb3DQEJ
      DzFFMEMwCgYIKoZIhvcNAwcwDgYIKoZIhvcNAwICAgCAMA0GCCqGSIb3DQMCAgFAMAcGBSsO
      AwIHMA0GCCqGSIb3DQMCAgEoMIGFBgkrBgEEAYI3EAQxeDB2MGIxCzAJBgNVBAYTAlpBMSUw
      IwYDVQQKExxUaGF3dGUgQ29uc3VsdGluZyAoUHR5KSBMdGQuMSwwKgYDVQQDEyNUaGF3dGUg
      UGVyc29uYWwgRnJlZW1haWwgSXNzdWluZyBDQQIQQz1aK1roIB9BhUog16WuhDCBhwYLKoZI
      hvcNAQkQAgsxeKB2MGIxCzAJBgNVBAYTAlpBMSUwIwYDVQQKExxUaGF3dGUgQ29uc3VsdGlu
      ZyAoUHR5KSBMdGQuMSwwKgYDVQQDEyNUaGF3dGUgUGVyc29uYWwgRnJlZW1haWwgSXNzdWlu
      ZyBDQQIQQz1aK1roIB9BhUog16WuhDANBgkqhkiG9w0BAQEFAASBgFNLrzLWTIUJDmDvSwhs
      /RfnKDCgmnYVy6GYxWaF1WsNF7M6Ugc64xSR0M7WFs9gjAXqJ9lwEX0hmyPKK/8Q2FMx6M6b
      dcksMoosx1hOtaig1R7/Pi1YJ14iRbEuazu352kp5C2FW1YPG6/zaA9+RixACdukmzqOGvIT
      1jKM7abzAAAAAAAA
      -------------ms010105030304030406070606-

      --===============1138503253==
      Content-Type: text/plain; charset="us-ascii"
      MIME-Version: 1.0
      Content-Transfer-Encoding: 7bit
      Content-Disposition: inline

      _______________________________________________
      http://lists.clamav.net/cgi-bin/mailman/listinfo/clamav-virusdb

      -===============1138503253==-

        Activity

        bago Stefano Bagnara added a comment -

        I would like to see more informations in bug reports!

        Does this problem apply to older james too?
        James 2.3.0a2 does not exists yet, do you mean you use James trunk?

        Can you post the sources of the before it is broken?

        The source problem seems to be a missin "Content-Type: multipart/related" in the main header, but you should provide a diff between the message received through james and a "correct" message.

        What mailets processed this mail before ending in your mail client?

        norman Norman Maurer added a comment -

        Yes im using current trunk..
        There are not many meailts only one that adding headers...

        I just add this to config:

        <mailet match="SenderIs=da@softcom.dk" class="ToProcessor">
        <processor>test</processor>
        </mailet>

        <mailet match="SenderIs=da@softcom.dk" class="ToProcessor">
        <processor>transport</processor>
        </mailet>

        <processor name="test">
        <mailet match="All" class="ToRepository">
        <repositoryPath> db://maildb/deadletter/clamav </repositoryPath>
        <passThrough>true</passThrough>
        </mailet>
        </processor>

        So we can see more tomorrow i hope ..

        bago Stefano Bagnara added a comment -

        you have a "test" processor with a single mailet with "passThrough=true". This is a wrong configuration: mails should never reach the end of the processor.
        You probably want to remove the passThrough from the test processor mailet and add it to the first ToProcessor mailet (If I understood your configuration).

        norman Norman Maurer added a comment -

        Please close this bugreport and reopen JAMES-433. The Problem only is reproducable when using AddFooter. So its a AddFooter Bug.

        danny@apache.org Danny Angus added a comment -

        Closing issue fixed in released version.


          People

          • Assignee:
            bago Stefano Bagnara
            Reporter:
            norman Norman Maurer
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development