Uploaded image for project: 'James Server'
  1. James Server
  2. JAMES-420

Sometimes messages are delayed or stalled in the spool

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.0, 2.3.0
    • Fix Version/s: 2.3.0
    • Labels:
      None

      Description

      There is a racing problem with notification.
      I'm able to always reproduce the problem in my developing environment.
      On other machines I had to add a Thread.sleep(1000) after the notify() of the MailRepository.store() to put evidence on this bug.

      PS: I already committed a patch for this issue. Just added this for future reference and to be able to have persistent comments.

        Activity

        bago Stefano Bagnara added a comment -

        Should be fixed, we just need real world testing.

        bago Stefano Bagnara added a comment -

        The #371100 fixed only a racing issue in File repositories.

        Another problem was in JDBCSpoolRepository since I changed a lot of MailImpl usage with Mail.
        I forgot to update the store(MailImpl) method in the JDBCSpoolRepository and it gave no error because the correct method was already implemented by the superclass (JDBCMailRepository). The overriding method was there to force a reload of the pending messages when a new message was stored... I hope #371292 fix this.

        danny@apache.org Danny Angus added a comment -

        Closing issue fixed in released version.


          People

          • Assignee:
            bago Stefano Bagnara
            Reporter:
            bago Stefano Bagnara
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development