Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.2.0
    • Fix Version/s: 2.3.0
    • Labels:
      None
    • Environment:
      fedora core 4, sun 1.4.2 VM

      Description

      i have started up james as root, and disabled all the servers except the NNTP server.

      i'ave successfully added several newsgroups

      clients are able to create messages and successfully post them

      when you then try to read one of those messages, the client will hang ('reading message') indefintely.. clients can see the message headers.. but when they try to click on the message, the body of the message will not appear. its as if the server is 'stuck' and won't send out the message body.

      have tried seveal clients (thunderbird mainly) and getting same behavior.

      nothing of note in the logs that i can tell.

      please advise.

        Activity

        gjlloyd gareth lloyd added a comment -

        actually, i did find this in the logs:

        24/06/05 09:07:16 INFO nntpserver: NNTP Service uses default thread group.
        24/06/05 09:07:16 INFO nntpserver: NNTP Service is running on: xxx.xxx.com
        24/06/05 09:07:16 INFO nntpserver: NNTP Service handler hello name is: xxx.xxx.com
        24/06/05 09:07:16 INFO nntpserver: NNTP Service handler connection timeout is: 120000
        24/06/05 09:07:16 INFO nntpserver: NNTP Service connection backlog is: 5
        24/06/05 09:07:16 INFO nntpserver: NNTP Service will allow a maximum of 30 connections.
        24/06/05 09:07:16 INFO nntpserver: NNTP Service started plain:119
        24/06/05 09:07:28 INFO nntpserver: Connection closed
        24/06/05 09:07:31 INFO nntpserver: Connection closed
        24/06/05 09:07:51 INFO nntpserver: Connection closed
        24/06/05 09:08:14 INFO nntpserver: Connection closed
        24/06/05 09:11:51 ERROR nntpserver: NNTP Connection has idled out.
        24/06/05 09:17:18 INFO nntpserver: Connection closed
        24/06/05 09:17:18 INFO nntpserver: Connection closed
        24/06/05 09:17:21 INFO nntpserver: Connection closed
        24/06/05 09:19:28 INFO nntpserver: Connection closed

        if thats any help

        gjlloyd gareth lloyd added a comment -

        sorry, one last peice of information.. when the client hangs when choosing a message, if you hit 'stop', the message does actually appear.. so it seems like the client is waiting for the server to send some kind of final acknowledgement of transmission.

        pezzer Daniel Perry added a comment -

        Looks like same issue as: http://issues.apache.org/jira/browse/JAMES-311 which has been fixed, but not in a release yet.

        Patch as follows:

        — NNTPHandler_orig.java
        +++ NNTPHandler.java
        @@ -1053,7 +1053,7 @@
        if (article != null)

        { writer.flush(); article.writeBody(new ExtraDotOutputStream(outs)); - writeLoggedFlushedResponse("."); + writeLoggedFlushedResponse("\r\n."); }

        }

        @@ -1189,7 +1189,7 @@
        if (article != null)

        { writer.flush(); article.writeArticle(new ExtraDotOutputStream(outs)); - writeLoggedFlushedResponse("."); + writeLoggedFlushedResponse("\r\n."); }

        }

        bago Stefano Bagnara added a comment -

        Duplicate of an already fixed bug.

        danny@apache.org Danny Angus added a comment -

        Closing issue fixed in released version.


          People

          • Assignee:
            Unassigned
            Reporter:
            gjlloyd gareth lloyd
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development