Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: 2.3.0
    • Fix Version/s: 2.3.0
    • Labels:
      None
    • Environment:
      James SVN branch truck-merged 20050504.

      Description

      Processor invoke store() on the spool when a message change its state but the message is still lockend and the notify called by the spool does not work (As far as I understand).

      I removed spool.store from the processor and leave spool handling to the spoolmanager thread.

      I also added a loop to the run of the spoolmanager thread so that it will process every state till GHOST or ERROR and not only one state at a time.

      1. JamesSpoolManager.java.patch
        5 kB
        Stefano Bagnara
      2. JamesSpoolManager.java.patch
        4 kB
        Stefano Bagnara
      3. LinearProcessor.java.patch
        8 kB
        Stefano Bagnara

        Activity

        bago Stefano Bagnara added a comment -

        Forgot to move an error logging in the right place.

        bago Stefano Bagnara added a comment -

        After a few more thought I think I've found the bug of this speed improvement.
        new MailImpl created by the LinearProcessor after a partial recipients match will never be persisted in the spool. So they will be lost after the end of the processor.

        Expect the patch soon.

        bago Stefano Bagnara added a comment -

        The patch submitted was invalid.
        I changed many code that could have optimized the spoolmanager but the change proposed in the issue is not applicable: to further improve the spooling we should change the spoolmanager interface.

        danny@apache.org Danny Angus added a comment -

        Closing issue fixed in released version.


          People

          • Assignee:
            bago Stefano Bagnara
            Reporter:
            bago Stefano Bagnara
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development