Uploaded image for project: 'James Server'
  1. James Server
  2. JAMES-1317

Mail spooled but not processed

VotersWatch issueWatchersLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Critical
    • Resolution: Fixed
    • 3.0-M1, 3.0-M2, 3.0-beta3
    • 3.0-beta4
    • None

    Description

      Mails sent to James server are spooled but they are not processed and sent out.

      The issue is similar to the one faced by Zach.

      The server seems to be working fine for a few hours or few days, but some time all the mails are spooled but they will not be processed and sent out. Restarted the server several times and some time a few of the mails will be processed and all the others are lost.

      As Norman suggested I have took a jstack trace.

      Please let me how we can resolve this issue

      Thanks

      • Raju

      Attachments

        1. Dump.txt
          439 kB
          Michael Herrmann
        2. Dump2.txt
          289 kB
          Michael Herrmann
        3. james-server-mailetcontainer-camel-3.0-beta4-SNAPSHOT.jar
          69 kB
          Norman Maurer
        4. james-server-mailetcontainer-camel-3.0-beta4-SNAPSHOT.jar
          69 kB
          Norman Maurer
        5. jstack.zip
          38 kB
          Raju Buchi
        6. logs.zip
          28 kB
          Michael Herrmann
        7. logs.zip
          58 kB
          Michael Herrmann

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            Unassigned Unassigned
            raju.buchi Raju Buchi
            Votes:
            1 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Issue deployment